Jag loses potentiometer reading

Our robot has a double jointed arm with a pot. at each joint.

During driver tryouts, we lost the readings from one of the potentiometers. The position was reading exactly 0. It was still connected as far as i could tell. It reads 0.3 and very noisy when disconnected. (since the signal lead is floating, its basically like an antenna)

We have it programed so the joysticks control the arms by setting %VBus. Pressing and holding a button will put it into PID control and move to the corresponding setpoint, release the button and it goes back to open loop.
So I was able to reconfigure the jag while it was running, but it didnt fix the problem. I had to powercycle it to get it back.
Oh and the open loop still worked with the joysticks, but my safety limits (in labview, not the soft limits on the Jag) had restricted the movement.

Anyone see this before? any way to fix it without a powercycle?

You lost the position from the potentiometer?
I’m almost certain it’s an electrical problem, but I won’t rule anything out until we have more details.
What are you doing when you lose the signal? Does it come back intermittently?

Also, it’d be nice to see how you’re configuring the Jaguar. Are you enabling it once you’re done?

The first thing to check is if the pot is still functional. Use a multi meter to verify that you have +5 volts across it. Then verify you are getting a variable signal out of the wiper as you move the arm.
Honestly, from the description you gave, it sounds like the pot is broken internally. Could it have been driven past it’s mechanical stop? If so, so bye bye to that one.

Good idea!
Make sure it is 3 volts across the potentiometer; the Jaguar only supplies 3v there, where the Analog Breakout supplies 5.

Did you say it worked again once you did a power cycle?

oops. forgot about this thread.

I think I found the problem. When switching between open/closed loop I had reinitialized all the closed loop params, but I forgot the feedback type on one of the motors. So it was looking for encoder pulses instead of the pot value.