Jag Motors Not Wired Correctly?

Hey guys,

We have the robot in communication with the driver and the robot code and communications is good to go, but when I push the joysticks forward or press any of the buttons it doesn’t do anything. The driver also says it’s getting the input because the joystick connection turns blue from green when a button is pressed. I haven’t tried checking the ribbon cable yet because I am not sure how to take it off, that’s electrical. But I have tried all the ports the motors can possible go into and it doesn’t make a difference. Along with everyone else, I’m getting camera real time connection issues, but that shouldn’t effect the motors.

Any help please?

make sure you wait 10 seconds to make sure that something is bad after you enable the first time

More then likely, that’s your issue.

Look at the Jaguar speed controller. There is an LED on it that tells you what the Jaguar thinks is happening. What the different colors and blink rates can be found in table 2-5 of this document:

http://www.ti.com/lit/ug/spmu022c/spmu022c.pdf