Jaguar Flashing Light Disable Problem

We found that our jaguar motor controllers disable (flashing yellow) when certain joystick inputs are reached. When we pull the two joysticks (tank drive) in the same direction, the wheels respond accordingly. However, when we push one joystick forward and the other back, the jaguars fail and no longer respond to any joystick input.

We are using the Drive/Four Motors and the Drive/Motors VIs in LabVIEW if that is any help.


Of course, it is possible that you have a bug in your code. However, you might want to be sure that you have a fully charged battery. The motor load may be pulling down the battery voltage.


An under-voltage problem seems unlikely–in our experience, the Jaguars have worked successfully at very low voltages(like 9v registering on the DS) and the code for undervoltage is flashing red light anyway.

By “fail” do you mean they just don’t execute the command, or that they stop responding to anything for a certain period of time?

If you’re using a four-motor drive system, you might have two of them swapped so they’re fighting each other during an attempted turn. This could perhaps end up pulling the battery voltage low enough to disable the PWM outputs but still not trip the Jaguars’ own low-voltage detection. Try taking out all of the drive motors’ circuit breakers and put them back in one at a time to verify that each motor does what you expect it to.

we found the problem we didnt have power going to the sidecar. Now everything works. Thanks for all the help