Jaguar Voltage Wrong

Team 1787 is experiencing an unusual issue from one of our Black Jaguar motor controllers from last year. We can connect the Jaguar with CAN and have installed the new firmware (version 101). When we tried to run the motor through the computer software, we discovered that the voltage was 12V too high. Thus when we tried to have the motor stop (set it to 0V), 12V would be output instead. Negative voltages decrease the voltage while positive voltages leave it unchanged. The computer software nonetheless reports that the voltage is as it should be. Does anyone have any idea why this may be happening?

How are you measuring this “incorrect” voltage? Can you show us your setup? What do you expect to happen compared to what actually happens?

Two questions:

  1. How are you measuring the output voltage? Is a motor hooked up to it? If I remember right, the Jaguar outputs a square waveform at all times, which makes measuring its output difficult. It’s best to hook up a motor to see what happens.
  2. What is the LED on the Jaguar showing?

The latest version of the firmware is 107 not 101. See this link below:


Good point… checking R68 shows:

If the CAN-bus configuration is used, the firmware on gray Jaguar motor controllers must be updated to at least Version 101 of the official FIRST firmware and Version 107 for black Jaguars.

Emphasis mine.

Thanks for all the replies!

We have the Jaguar powered through the power distribution board, which is connected to the battery and voltage is being measured using a multimeter. The Jaguar is being controlled using the BDC-COMM software. Another Black Jaguar (from the 2013 KOP) is attached in the same configuration and works properly.

When attached to a motor instead of the multimeter setting the voltage output to 0% (or 0 Volts) results in the motor being driven at full speed. This differs from the expected result of the motor not spinning at all.

Setting the voltage (using the BDC-COMM software) to a negative value decreases the voltage read by the multimeter. For instance setting the voltage to -5V results an output of around 7V, while setting the voltage to -12V results in an output of -0.3V. Increasing the target voltage above zero has no effect, as the output voltage remains at just over 12V.

Thanks for pointing out that the proper version of the Black Jaguar firmware is 107. We will certainly upgrade at our next meeting. Nonetheless, since our other Black Jaguars running the same version of the firmware are working fine, I suspect that this is not the (only?) issue. It sure would be an easy fix if this were the problem though!

Look up the Jaguar documentation/manual. You should be able to find the calibration procedure in there. Hopefully following that will help you fix the issue! I’de provide a link, but I’m sending this from my phone…

Remember that the output of a speed controller is PWM and it changes the pulse width to change the average current in the motor. Reading the output with a multimeter will not give and accurate reading except at full throttle. If you are measuring the output of the speed controller with a multimeter, the polarity of the voltage you read will change depending on direction and throttle levels.

*You can indeed measure the output voltage of a motor controller without a motor, using an inexpensive multimeter. I’d recommend putting a 1500 ohm resistive load across the output. Use the DC setting of the multimeter. This was done using a Velleman DVM850BL: