Jaguars and Motors

We work the LabVIEW example programs but motors aren’t running. We think we have a problem with Jaguars; cause everything looks fine. We tried everything but it didn’t work. Did you have the same problem? Or you know the solution??

Do you have jumpers installed in the overtravel limit inputs on the jaguar?

what color are the lights on the jaguar?

If you plug a standard hobby servo into the same port, does it move as you expect? (You can use a Y cable to have both a jaguar and a hobby servo on the same channel.)

This servo test also requires that a jumper be installed next to the PWM you have the servo attached to.


I wouldn’t connect both the jaguar and the servo at the same time, primarily because the jumper needed changes the voltage to the servo.

Check your PWM’s are in the right way. Test everything out with servos (if you have enough) and the jumpers for the servos on the sidecar. Then, if that doesn’t work, go into Labview and make sure you set everything right. The program won’t be the issue, but the parameters you set could very well cause issues. First, make sure you set your team number as your CRIO IP. Then make sure the PWM ports you picked for the Motors are indeed the ones you are connected to. Ive done that before (on last year’s robot, my team for some mysterious reason had the motors connected to 3 & 4). You could also have the sample program set to victors instead of Jaguars, but I doubt this would cause 0 movement.

That’s about all I can think of for easy fixes. I’ve always been a huge fan of VIctors- they have less to go wrong and take up less space. If the jaguars are being problematic, I’d try to scrounge for a couple simply for testing purposes. (They are wired pretty much the same- except instead of color-coded screws they have molded lettering.)

-Ed C
VP & Head Programmer
Team 2064

I’m sure you didn’t try everything. Otherwise you would have found the solution. :stuck_out_tongue:

Let’s find out what you did try, and perhaps we’ll notice something you overlooked. Please tell us, in as much detail as you can, how you have connected your motors and Jaguars to the control system, and how you are running the program. Let us know what lights are blinking, what messages you are seeing on the screen, and what buttons you’re clicking.

We are also having big problems! We have a test board all wired up and lights seem to indicate that it is working correctly when powered up (Jaguars flash, green power lights on sidecar (all of them…), etc. We have imaged the cRIO (v. 18 I think) and that seems to work fine. When we load labview code to test out a motor it does nothing. We also tried a servo but got nothing.


  1. Does the stop button need to be plugged in for everything to work? If it is not plugged in, does everything need a reboot after plugging it in? What about the robot light (I assume this is not needed?)

  2. If we put a digital voltmeter on the PWM outputs, what kind of readings should we get when trying to drive a Jaguar, and what kind of readings should we get when operating a hobby servo?

  3. After uploading the labview code do we deploy by just hitting the run button at the top?

  4. Any other ideas?


  • You must have the E-stop button plugged in for the robot to be enabled. No reboot is necessary unless you actually push the button, and then it’s the robot that needs to be rebooted, not your PC.

  • You must also run the Driver Station from the Developer account if you want to use the LabVIEW “Run” button. Exit the Driver account to work in the Developer account, do not just switch users. You’ll find “FRC Driver Station” under Windows Start -> All Programs. You have to click on the Driver Station Enable button to get the robot operating.

  • The LabVIEW “Run” button is temporary. The program will stop if you switch user accounts, log off, or reboot the robot. To put your program on the robot so it will run whenever you turn your robot on or reboot it - it must be built, then “Run as startup.” You’ll find both of these on the LabVIEW Project Explorer window at the very bottom under “Build Specifications” and the file listed under it (right-click).
    Status lights:

  • The Driver Station will have lots of status lights on the Diagnostics tab to tell you what’s working, and what isn’t working.

  • The Jaguar lights should not be blinking when they are at rest. Blinking means the robot is disabled or the code or wiring is not correct. The status lights will be solid yellow when neutral, or red/green when driving.
    *]There is a status LED on the Digital Sidecar that is probably blinking as well. The Robot Status Light is just a repeater for this LED, so you don’t need the RSL right now. For competition, yes.

A voltmeter is not he best tool for measuring the PWM output (measured from Black to White/Yellow), but you can get an idea of what the voltage would be using the meter in DC mode. A typical servo signal at neutral will be 1.5 ms at 5V and 18.5ms at 0V, giving an average voltage of 0.375V. Max reverse is typically 1ms (0.25V avg), and max forward is typically 2ms (0.5V avg), so you need a good meter to read this.

If your robot is disabled, you will probably get 0V on the signal.

If you can get your hands on an Oscilloscope, it’s a great signal to watch, and is a good learning opportunity about test equipment.

I think you do need to get your Driver station E-Stop hooked up as mentioned above. This seems like the most likely barrier to your tests working. One person should be assigned to hold it in their hands at all times during robot testing, in case something bad happens. I assume you’re not looking to put any holes in the walls or the people on your team ::safety::