Jaguars With RS-775 Faulting

We are running a 775 through a cimulator for our shooter, and our jaguars keep going into fault mode whenever we try to spin it up.We have switched it with victors for now, but does anyone know why this would be happening?

Jaguars tend to brown-out easily due to a large drop in voltage.

I would first check to see if all your connections from the power distribution board are tight. Check to see if the wires in the WAGO terminal are stripped enough. Sometimes they clamp on the insulation, and supply enough juice to power on the Jag, but once you start actually running it, the resistance causes a big voltage drop.

The screw terminals on the Jags themselves can sometimes come loose as well.

Are you running the Jaguars via a PWM cable? or CAN?

We tried both CAN and PWM. Its the built in overcurrent protection that is faulting, but it doesnt happen on our drive which is also jaguars.

Sounds like your inertia load is high. Try putting the Jaguar into ramp mode by the jumpers. If it working on victors, just run them on victors?

would the ramp mode actually work?. It gains a little bit of speed and then shuts off for 3 seconds, then trys again and resets again

Try slowly ramping up the power to the motor instead of setting it to 100% instantly. The Jaguars have internal overcurrent protection which tends to trip at abrupt changes in power, especially with large loads. A good indicator of this happening is a yellow light on the jaguar blinking for 3 seconds when this happens. The length of time it blinks will always be constant in an overcurrent fault.

Jaguars will not brown out due to low voltage until 6 volts, you can test if this is the problem by looking at the voltage reading of the overall robot from the driver station. Using a battery with low charge will usually be the culprit in this situation, but I wouldn’t expect a single 775 to drop the voltage of the entire robot enough to cause this problem unless the battery was already mostly discharged.

It’s simple to add a slew rate limiter to the motor command:

http://www.chiefdelphi.com/forums/showpost.php?p=1127623&postcount=2

You can set the slew rate so the Jag’s don’t overcurrent.

How much ramp should we add. it would have to be over 2 seconds because it runs for about 2 seconds then stops.

Experiment. The tuning constant “limit” determines how much the filtered value will be allowed to increase (or decrease) every 20ms (if you’re running it in TeleOp).

So you could start with a zero-to-full-voltage ramp time of 3 seconds. Thus, if “+1” represents full voltage, then “limit” should be set to .02/3 = 0.0067. It will take 150 20ms periods (3 seconds) to ramp from 0 to +1.

By the time it gets to +1, it will probably be spinning fast enough that you won’t overcurrent.