Java Deploy for Debug not functional?

Is anyone else having issues with the java debug deploy option this year?

We are using eclipse Neon on windows 10, 64 bit. We can create a brand new iterative robot project (leaving the boilerplate code in) and deploy it without issue to the RIO.

However, the debug deploy does not appear to do anything. Eclipse flips over to the debug perspective, but we get no console output, nor does the RIO appear to restart. Nothing shows up under any of the debug window panes…

Anyone else seen this yet? Or if not, and ideas on where to start debugging?


EDIT: Installed ant 1.9.7 independently on my computer, and ran “ant debug-deploy” in the root directory of the project. Got the following output:

     [echo] [athena-compile] Compiling src with classpath=C:\Users\Chris Gerth\wpilib\java\current\lib\WPILib.jar;C:\Users\Chris Gerth\wpilib\java\current\lib\NetworkTables.jar;C:\Users\Chris Gerth\wpilib\java\current\lib\opencv.jar;C:\Users\Chris Gerth\wpilib\java\current\lib\cscore.jar to build

     [echo] [athena-jar] Making jar dist/FRCUserProgram.jar.
     [echo] [athena-jar] Copying jars to build/jars.

     [echo] Trying Target: roboRIO-1736-FRC.local
     [echo] roboRIO found via mDNS

     [echo] roboRIO image version validated
     [echo] Checking for JRE. If this fails install the JRE using these instructions:
  [sshexec] Connecting to roboRIO-1736-FRC.local:22
  [sshexec] cmd : test -d /usr/local/frc/JRE


C:\Users\Chris Gerth\wpilib\java\current\ant\build.xml:192: required attribute libs.deploydir not set

Total time: 7 seconds


Looking at that line, it would appear in fact that libs.deploydir is not set… is this possibly a version of ant thing?

Edit2: Confirmed that by editing C:\Users\Chris Gerth\wpilib\java\current\ant\build.xml to have the same libs.deploydir that the debug target has gets the build to complete successfully. Seems to be working in eclipse too, although I have to manually relaunch the Remote Java Application on the RIO to start debugging. To Github to post a PR!

I didn’t see this error but will try it. Can you post what you specifically changed? Much thanks, I thought I was going stupid has the change.

That file ends up in your {user home}/wpilib/java/{version}/ant folder on your hard drive.

I tried this and no luck, I did a RunAs and WpiLib Deploy, then debug. I see the same error in the Error Log.

I have a similar issue as the original post. I am using eclipse Neon.2 version 4.6.2. 64 bit. C++ environment. Windows 10. I grabbed one of the example programs. I indexed it and built it. When I tried to deploy it the eclipse console did not show any activity and the program did not deploy. I tried turning the windows firewall off. Not change. I do have a connection to the RoboRIO – I can log into it using windows explorer at IP address

Try a regular deploy, there is an issue with java Debug deploy.

Is there an ETA on the fix? I just started mentoring (C# developer by day) What do I need to do get fix? Do I need to clone the Eclipseplugins and rebuild? I would like to be able to debug. It sounds like this also is affecting C++ too. We can certainly get the team going without debugging but it will certainly help me understand what’s going one.

We are seeing the same issue with the Java Debug Deploy - it switches to the debug view but does nothing else. Run Deploy works fine. But not having debug makes things a bit difficult

This seems to be a new issue in the 2017 WPILib. I start debugging but Eclipse will freeze for about a minute and then there is nothing logged to the console and no debug session was started.

On Eclipse in Linux I was able to start debugging once and then subsequent sessions would freeze.

The only reliable workaround for me has been to install 32-bit Java and Eclipse on Windows.

We are seeing exactly this right now. If anyone knows a workaround besides installing everything 32 bit I would love to hear it.

We were able to fix this by connecting to the robot. Turns out thats how the debugger is supposed to work. :o

Not sure if this will solve the problem for everyone but the debugger has been working since we did this.

“We were able to fix this by connecting to the robot. Turns out thats how the debugger is supposed to work.”

We are having this same problem. Could you please clarify what you mean by “connecting to the robot”?

Not sure on overall ETA, although I"m going to try to see if I can get a workaround going tonight if I have time.

The fix to the ant build referenced in this thread that I (and others) looked at is merged here: - you can potentially manually update the files in your [home]/wpilib/*/build folders to check out if it gets you any further. However, any of the other issues might require re-compiling the plugin (which I have not attempted yet)

For all the folks saying they’re freezing, let eclipse run for at least five minutes to see if you get control back. If you do, check your error log and see if you have symptoms similar to this other thread: … I’ve got an issue in at for what I"m seeing, but I’m still trying to nail down if it’s a “just me” or “everyone” thing.

EDIT: Debugging progress last night: no dice yet. I was able to manually coax the RIO into debugging mode by creating the /tmp/frcdebug file and restarting the user code, and got eclipse to connect by manually creating a debug target (with the RIO’s address and port). However, eclipse still was giving warnings about line number annotations not being turned on (despite the fact that we have debug=“true” in the javac tag in the ant build). Still learning as I go, but I’m worried that I’m getting too far down the rabbit hole in the wrong direction…

There was a new version of the plugins for eclipse 2017.2.1. This seem to fix the debugging issue. I only tried once in Java as we moved to C++. The students were about split between Java and C++ and since we could get things going we went that direction.