Java deploy not working

I recently installed Windows 10 (clean install) on our programming laptop and after following the usual steps to install Eclipse and the WPILib plugins, I can’t get the code to deploy to the RoboRIO. When I do the “Run As->WPILib Deploy” the console window pops up, but no messages appear at all and the code isn’t getting downloaded.

Things I have tried:

  • Make sure that Eclipse is pointed at a JDK, not JRE
  • Tried both wired and wireless connections to the modem
  • Tried turning off Windows Firewall (although it looked like the settings were correct to let everything needed through)
  • Tried connecting wirelessly and disabling the wired ethernet hardware

I know the RoboRIO and modem are set up correctly as I was successfully downloading code before the new install of Windows 10 (it was using Windows 8 before).

Ideas? Suggestions? At this point I am ready to uninstall Eclipse and reinstall it again to see if that makes a difference.


I have had similar issues and found that uninstalling eclipse did not help.