Java Language Support Crash

We’ve started running into an odd error in VSCode when opening up our robot’s java code:
The Language Support for the Java server crashed 5 times in the last 3 minutes. The server will not be restarted.

It shows up even without building the code. My initial attempt to fix it was restarting the computer and rerunning the latest version of the WPI/VSCode installer.

I had found an old post (link) where someone had a similar issue pop up while trying to fix an error with building the code; their fix was rerunning the installer, so I gave it another go.

Looking up the error, I found recommendations to clean the java language workspace and reinstall the java extension, but that didn’t get me anywhere.

Has anyone else encountered this issue before?

You may have noticed that other similar posts had to do with installing and uninstalling extensions. When you do get it cleaned up don’t run the last thing you did again. There is a rather loose connection between the WPI installer and VSCode installer. Maybe delete the WPILib stuff and uninstall VSC in Apps & Features (Windows remove programs) and start over? It’s easy to uninstall and reinstall VSC so do that first.

Well, I cleared everything out and re-installed it. I did get a new error, though:

Could not create an instance of Tooling API implementation using the specified Gradle distribution ‘https://services.gradle.org/distributions/gradle-7.3.3-bin.zip’.
org/gradle/process/internal/health/memory/OsMemoryInfo
org.gradle.process.internal.health.memory.OsMemoryInfo

I tried making a new template in VSCode for the robot code to see if something had happened with our old code, but the same error pops up.