Java to Crio Downloading Issues

My team is using Java to program our robot, and we want to put a simple project we created onto the Crio. We have imaged our Crio and have set the laptop’s IP address. When loading the code, Netbeans gives us this message:

Target IP: 10.35.6.2
Network interfaces on host:
    Realtek PCI FE Family Controller: address: 10.35.6.7 netmask: 255.255.255.0 <--- on robot's subnet
Connection FTP @10.35.6.2

And then it stops. It doesn’t give an error or anything. Does anyone have any idea what’s going on?

The computer is unable to connect to the robot. There is likely an iphone address set incorrectly somewhere.

Ok, we got it. It turns out I overlooked firewall. Stupid firewall. However, now we’re running into a new issue. Netbeans is now giving us this message:

Waiting to connect to OTA command server of 10.35.6.2:8001 for past 43s
Waiting to connect to OTA command server of 10.35.6.2:8001 for past 44s
Waiting to connect to OTA command server of 10.35.6.2:8001 for past 45s

It keeps going on. My friend says it should work in 7 seconds, but now it’s at around 700. Does anyone know what this means and how we can fix it? Thanks to anyone who helps.

You need to restart your crio and download once more. This happens once after imaging the crio.

Cool! That works. Now we just need to get the actual code working :slight_smile:

Glad to hear it works. You should try some of the examples.

We are having a similiar problem when we try to deploy the code onto the CRio the program stops without a build error at

[cRIO] Default disabled() method running, consider providing your own
[cRIO] task 0x25c7a58 (System Web Services Load Thread) deleted: errno=0 (0) status=0 (0)
[cRIO] task 0x2869f70 (mDNS resolve) deleted: errno=0 (0) status=0 (0)
[cRIO] task 0x2bff0d0 (mDNS resolve) deleted: errno=0 (0) status=0 (0)

I have tried almost everything i can think of so any help would be strongly appreciated.

Thanks,
F.I.R.S.T. Team #4021

That is displayed whenever you finish deploying the code.

I have had this same problem aswell. When you say restart do you mean pressing the button on the or cutting the power off and then turning it back on? And should this be done while the code is trying to run?

You will need to power cycle the entire robot. You do not want to power cycle the robot while it is running the code.

It’s a known bug since last year.

SOP for flashing/updating the crio:

  1. Flash it
  2. Upload code
  3. Reboot the crio
  4. Pretend nothing happened and upload code
  5. Success.

This same thing happens when I deploy code to our cRIO. It gets to the mDNS resolve and hangs. I’ve found that if you just stop the process it deploys the code correctly, it just seems to get hung up after its finished deploying for some reason. It says that there is robot code when we switch to the driver station and any changes we make work even though it hangs.

The deploy process is not supposed to “finish”. It stays connected to your robot in order to display any output that your robot or the cRIO prints out.

This message is printed by WPILibJ if you haven’t overridden the disabled() method (which isn’t a requirement by the way):

[cRIO] Default disabled() method running, consider providing your own

If you see that message, then it’s very likely that your robot code is running fine.

This message is printed by the cRIO for some reason. I think it is an ordinary status message though, not any real problem:

[cRIO] task 0x25c7a58 (System Web Services Load Thread) deleted: errno=0 (0) status=0 (0)
[cRIO] task 0x2869f70 (mDNS resolve) deleted: errno=0 (0) status=0 (0)
[cRIO] task 0x2bff0d0 (mDNS resolve) deleted: errno=0 (0) status=0 (0)

For your own sanity and/or peace of mind, you might want to print a message at the beginning and end of your disabled(), autonomous() and operatorControl() methods - something like “entering autonomous mode”, “exiting autonomous mode”, etc.

hello, we are having the same problem as you, we dont have any firewall running that we know of and have had 3 people check it. Can you tell us what you did so we can try to fix ours?

we try to send code but get the same error that says connection has timed out and we can’t figure out why…

heres what we get…

Target IP: 10.0.0.2
Network interfaces on host:
Intel® 82567LM Gigabit Network Connection: address: 10.17.43.5 netmask: 255.0.0.0 <— on robot’s subnet
Intel® WiFi Link 5100 AGN: address: 10.10.12.154 netmask: 255.255.255.254
Connecting FTP @10.0.0.

we are thinking we need to change the target ip address to the 10.17.43.5 but are unsure of how to do this and are trying to figure out if this is the real reason for our problem…

There is a netbeans configuration option to change, in the menu:

Tools -> Options -> Miscellaneous -> FRC Configuration

Change your team number.

This step is missing from [1]. Their section on Netbeans is a little sparse and references an older version (6.7). No one took credit as author on that document to suggest this change.

[1] http://www.usfirst.org/sites/default/files/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2012_Assets/Getting%20Started%20with%20the%202012%20FRC%20Control%20System_2.pdf

Open up your netbeans settings, click the miscellaneous tab, click the FRC Java tab, and set your team number in there.

thanks, we have done that and will test it in a few hours. I will respond back if it works.
when we set it in netbeans we got set remote address to (10.17.43.2) which i am going to assume is correct?

also…
using command prompt and the ipconfig command,

we have the:
IPv4 - 10.10.12.154
subnet - 255.255.0.0
default gateway 10.10.0.1

we are team 1743 so i know it should read (10.17.43.6) there…

but i am unaware of what it should correctly read… Can someone post up an accurate example of exactly how it should be?

What is your exact setup? If you use the wireless router on the robot as an access point, you don’t need to configure the default gateway on your computer. Disable DHCP on the router and manually change your address to 10.17.43.x, where x is an integer 0~255 and not 1, 2, 4 or 6, or 11 (to be safe).

so we fixed the ip address issue (thanks for the help)

now we got another issue (lol)

we are getting an error where it says looking for frc_2012_v43.zip but got frc_2011_v28.zip

we tried looking for where it is calling for this file path but we couldn’t find it… our netbeans is updated to the fullest and has all of the plug-ins installed…

Two things you should try:

  1. Update your cRio flashing utility. The 2012 version has some major changes done to it.
  2. Uninstall, reinstall the plugins in netbeans. Those plugins should contain the cRio image files.