Is there no support for Javadocs in the WPILib this year? I looked in a few of the source files and saw no Javadoc formatted comments.

I looked through a few (RobotDrive Jaguar Victor and DoubleSolenoid) and they all had plenty of JavaDoc comments. Which particular classes did you look at?

Bizarre. I think I started with Accelerometer and looked at the first few and then Gyro. I’ll look again tonight, maybe I was just too sleepy. Thanks for the reply.

The Javadocs are still there. On Windows they are in


Or wherever your sunspotfrcsdk is.

You can even attach Javadoc toi the WPILib classes in netbeans by clicking “Attach Javadoc” when the “No Javadoc Available” stuff appears on a tooltip by pointing to …/sunspotfrcsdk/doc/javadoc .

Also, the WPIlib source may not be attached to the library in Netbeans.

If when you view the source you see lots of sections saying “compiled code” then you will also see a button to “Attach Source”. The source will be in: /sunspotfrcsdk/lib/ I believe. Just attach the zip file, you don’t need to extract it.

Not to get off topic, but I did unzip them. In past years I’ve needed to modify and rebuild, and I figured it would help compile time.

I generated the doc. Attachment is below.

FRC 2013 - Java (2.09 MB)

FRC 2013 - Java (2.09 MB)

Everthing is fine (except my brain :o ).
Code Folds -> Expand All JavaDocs
made everything appear.

so we have been having this issue as well ( we are trying to trouble shoot some things with the robot and none of the java docs are loaded)

we have gone in and loaded the java docs from the user sunsp/docs/javadocs in the tools->java platforms section , and from the .zip on this page, but Netbeans still doesn’t show the java docs.
we have attempted attaching the javadocs from each error ( with ctl +F1), still no good ( BTW it asks for wiplib and sqwak attached to either the local or the .zip still shows an empty javadocs)

we have verified that the local location html files are populated ( and work). we have verified that the supplied zip html files are populated ( and work).

this is on all 4 of our computers 2 Windows 7 and 2 Windows XP

any additional info or help would be greatly appreciated

Did you follow Big J’s advice above (post #4)? It worked for me.