Jetson TX1 does not power on

We have 2 Jetson TX1, and both work when plugged into the 120Vac power supply. However we are unable to get them to power on while on the robot.

We have a regular robot, battery to a breaker, to a PDP. We have a variable boost buck power supply (80W variant) to give a regulated 12V to the Jetson. We have verified that the it outputs 12v with a voltmeter. We are plugging into the Jetson with a barrel jack.

When we turn the robot on, we see the standby LED illuminate. However when we push the power switch, the SOC LED flickers on, as well as CR6. Then the Jetson returns to standby.

I then tried putting a 220uF electrolytic capacitor on the output of the power supply, hoping it would fix a voltage drop due to inrush current. This did not help.

I then tried using a bench top HP power supply set to 12V and that did not work. I had to raise the voltage to 15v before it powered on.

I was told a workaround would be to rapidly press the power switch and it would power on. This worked for a few days, however now pressing it rapidly does not get the Jetson to power on.

We then tried setting the boost buck to 19v, which is the higher end of the Jetson’s input voltage range. We get the same issue, it enters standby but only get LEDs to flicker.

Any ideas on the root cause, or the fix? We have 2 separate DC-DC converters and 2 separate Jetson TX1s and no configuration of them works. How are teams successfully powering their Jetson on the robot?

Sounds like you hit all the major points… We did have some issues with the first set of barrel connectors we tried to use - they weren’t quite the right size (but the same spec - /shrug). Have you used those connectors successfully before?

One thing my team discovered last year about the TX1 is with the default carrier board, the Jetson doesn’t power on with 12 volts. It will run at 12 volts but to start it, it’s needs an input voltage that is higher. The power brick that comes with it is set at 18 or 19 volts I believe? I believe our booster is set at 18 volts right now to use on our robot.

  1. My electrical guy said Jetson need 19V like @Type said.

  2. You can also change current on output to 4A and connect DROK to PDP .

  3. Let’s make Unter Volt at DROK to 8V

Good luck!

This is our first year using a Jetson on a robot. We did get it to power on a few times, however it was not consistent.

I agree with 1. The documentation gives a range between 5.5V and 19.6V, so 12V should have worked.

I don’t quite understand your 2nd and 3rd point. The DROK doesn’t have a current controlled output, and the DROK is connected to the PDP. I don’t see how running it at 8v would help, but I can give it a shot on Tuesday.

Off topic: I’ll see you at Shenzhen and Shanghai.

Here you can see where is the regulator. I hope you have that.

PS. It will great to see you in China regionals.

Ah, I’m using the one that comes in the metal case, and it does not have a current adjustment.

My working theory:

The TX1 is rated for 5.5v - 19.6v, however that is without the board it’s attached to. I do remember having some issues when we first got our buck boost (the one in the picture in the link above), but we took a meter and measured the output of the power brick it came with and dialed in our buck boost to match. Haven’t had a problem since.

If your buck boost isn’t adjustable, and you’re locked to 12v, you may need to replace it. At a minimum throw a meter on the power brick that came with the Tegra and confirm it’s around 19v. If you’re getting flickering lights, perhaps the buck boost isn’t able to provide enough amperage?

Try one of these guys if you are looking to power the TX1 or TX2 off of 12V, we use these on our Mars Rover and it works flawlessly.

I think we found the root cause. We ordered a new power supply.

I was watching the electrical student install it, and when he plugged the stripped side of the barrel jack into the converter, he got 0 volts between the inside and outside. We did have the barrel jack going into a size converter. It turned out, the outer diameter of one of our barrel jacks was 5mm, when we needed 5.5mm. If I pressed on the size converter, it would work. The other cable we had was 5.5mm and when we used that one, it worked fine.

We set the regulator to 19v and it powered on the first time. I feel that the size of the barrel plug was the issue all along. bdaroz got it right in his first post.

Thanks everyone