Joystick Button being detected but riolog saying its not being detected

So our team was trying to test our robot, but we are getting this error “Joystick Button 1 on port 1 not available, check if controller is plugged in”. We went into usb devices on the driver station and when we press a button it shows up as being pressed in the driver station. Our code worked before and nothing has changed since but now we are getting this error.

Are you using the DriverStation that was just released (23.1)?

Does this persist even if you close and reopen the DS and have the joysticks connected before connecting to the robot?

We are on driverstation 23.0 and just tried DS having joysticks connected before and it still didn’t work.

I see that the RioLog is paused. Just to make sure, these errors are being printed in real time? They’re not from a previous run?

Yea it happens in real time I just had it paused since the error kept repeating so it was hard to take a picture

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.