Kinect SDK and Server Woes x64

Ok, so we recently got a new laptop (yay!) and started to load all the necessary software. When it came down to the Kinect, we installed Visual Studio C# Express first, then the SDK (x64), and finally the Server. Problem is however, the server won’t install.
We were able to troubleshoot it down to the source of the error, the environment variable. On our x86 classmate, there is a variable KINECTSDK_DIR and a specific location, which are set by the x86 installer. On the x64 installer, on the other hand, we have MSRKINECTSDK (or something of the sort). Because of the difference in variables (and paths), the Kinect Server won’t install. Now I’ve tried changing the install directory to the x86 variable path, but that gave us no luck because:

  1. We don’t know what in particular the path is locating (.dll or .xml?)
  2. The installation automatically splits the install folders, some going into x64, some going into x86
    I’m sure other teams have come to this problem… Any solution? We basically need the Kinect Server to find the right DIR without throwing an error when we open up the Driver Station.

We have tried installing the x86, but the installation process ends “prematurely.” Unfortunately, the Event Viewer doesn’t give much helpful info :frowning:

This thread on the FIRST Forums might help

I’ve seen that already and the installer doesn’t create such a variable. The path doesn’t exist either

The Environment Variables should be the same between the 32-bit and 64-bit installers, otherwise the variable isn’t particularly useful. Are you sure they’re different? Have you tried re-downloading the Beta 2 SDK from I had previous versions of the SDK installed from some pre-season familiarization with the Kinect and I believe the Beta 1 SDK created the MSRKINECTSDK variable.

If you can’t get it figured out I’d post to the FIRST forum and see what they have to say.

I MIGHT’VE figured out the problem. I downloaded the sdk from dreamspark, not from
I’ll test it tomorrow and let u guys know sdk works :slight_smile:

Strange that Dreamspark has an old version up. Glad you got things worked out!