LabVIEW autonomous

I put that in to make my robot drive forward but it doesn’t work

Are you selecting “Tour Turn” in the Dashboard’s Auto Selector before running Autonomous?

Please help with more information about your code and what you have already tried to receive better help.

  • Do you see any errors in the Driver Station’s messages/console?
  • How does your Begin.vi look like?

no errors in the drivers station don’t see an option for your turn

wait i see what you mean I think I got it I’m going to try it now

@oscarfonloz It didn’t work

Consider retaining probe values in Autonomous Independent.vi and running Robot Main.vi after. Once you enable Autonomous in the driver station, you should be able to probe the wires and see if the code went to the correct case in the case structure. Furthermore, you can try Highlight Execution on the VI and ensure the code is being executed as you expect.

a recommendation I have for Begin.vi is to add “Your Turn” to the array that writes the options to the Dashboard autonomous dropdown. You can find it here:

ok thanks

I got it working