LabVIEW Can't Find FPGA DLL

A few days ago, when I was opening up a cRIO project, I discovered that I couldn’t access any VI’s intended to go on the cRIO.

http://i.imgur.com/P4NZQBH.png?1
http://i.imgur.com/szVFndd.png?1

This was on a project which I was before able to open on my laptop without any problems before, and I am still able to open it on other computers. I tried other projects, and they did the same thing. New projects also produced the same result, although they gave this error when created:

Error 1055 occurred at Property Node in FRC Create Project.vi->FRC Wizard - Robot.vi

At first, I ensured that my licence was working, and attempted to re-install the 2014 FRC Update Suite. No dice. Next, I went in “Programs and Features” on my control panel, and repaired every single National Instuments file on my hard drive. Still nothing. Finally, I had to spend about 5 hours today uninstalling every piece NI software on my laptop, and then re-installing it. But this error has managed to survive even that. So I decided to look into it more. When attempting to bypass the project manager and open a VI directly, I got this error:

http://i.imgur.com/H3oFHRF.png?1

It did manage to open after I clicked OK, however I discovered that all of the WPIlib subVIs for setting and getting actuators, sensors, etc had errors. Digging to the source of the errors, I got this:

http://i.imgur.com/BJLFa5Z.png?1

That property node is the source of all my problems. I have no idea what to do. My team was depending on me to code some important stuff today, but so far I have done nothing but chase down this problem. If re-installing didn’t work, I don’t know what will.

I think what you’re seeing there is a red herring. It’s probably complaining about the FPGA dll because you’ve opened the VI in a “My Computer” context instead of a “RT CompactRIO Target” one, and the FPGA only makes sense on the cRIO.

My advice is for you to call NI technical support about this one. If you go to http://ni.com/frc you will see the contact info:

Support.
During build season call 866-511-6285 between 1:00-7:00 PM CST to speak with a National Instruments Applications Engineer. They will be able to assist you with LabVIEW and cRIO questions.

I would also recommend calling NI technical support. It appears that the RIO driver is no longer responding, wasn’t installed, etc. That is why your RIO target doesn’t show up in the project. They can use Max and Windows install tools to troubleshoot. Be sure you have the CD and laptop with you when you call.

Greg McKaskle