Labview CMUCam2 GUI Serial Drop Out Problems

I’ve got a weird problem with communication with the CMUCAM.

I’ve got a DELL D820 Laptop, Windows XP PRO, and a “real com port”. COM1 to be exact.

I loaded NI 8.5 today on my laptop for the first time and loaded up the CMUCAM GUI software from 2006.

When I try and do frame grabs or tracking, the serial communications to the camera times out randomly. It’s quite annoying…I dunno why it does this.

We have an OLD, OLD Dell Optiplex desktop machine, Windows 2000 Pro, and I can connect to the CMUCAM no problems, no serial port time outs at all.

But I am getting these serial port time outs on my laptop.

I’ve done the following:

  1. NI 8.5 (from the KOP 2008)
  2. NVISTA (serial port driver is installed) from the KOP 2008
  3. I have a “real” serial port, no USB>serial garbage here
  4. I set my serial port in PORT/LPT to 115,000
  5. I tried three different cables, and the shortest one I could find, about 10 feet
  6. I unconnected the TTL PWM while I am connected to the DB-9 port on the CMUCAM.
  7. I am running Windows XP PRO, not vista…
  8. I can talk to the camera all day long, and track data on the camera with NI 8.5 loaded on a slower machine.

Why would my new Dell D820 Laptop drop serial communications all the time?

IS there some timeout setting I can adjust somewhere so it won’t timeout so quickly? Thanks

Unfortunately you’ve given me every single piece of information that you could possibly give me EXCEPT the error that you’re getting. Is there a specific error message in the dialog box that you’re seeing?

Slow machine working versus fast machine not working screams a race condition somewhere. If you can give me a little more info (a screen capture would be better) I might be able to help you.

-Danny

Sorry took me a bit to get back online…

As you can see, I start to do a frame grab, and it starts to grab the image, then quits. I get the following two errors, screen 1 and screen 2.

I’ve tried ASRL1 setting for com, and actually selecting COM 1 in the pull down, it’s no difference.

Screen 3 is a good frame grab, then if I click on tracking, that’s screen 4, it tracks for a few seconds, then the serial errors out.

Again, it doesn’t do this on the slower PC, just my Dell D820 laptop. The D820 has a built in COM port. It’s the Latitude series.

EDIT:
Also, we use a CUSTOM circuit, a 7.2 volt charger which converts 12 VOLTS to 7.2 VOLTS to the camera. The power to the camera remains good.