LabVIEW currently cannot load the selected item

So I just downloaded the latest version of LabVIEW and when I went to open my project up, the “Target” has a caution symbol next to it. When I right-click it and press “Explain Warning” I see this message, any help?

Did you download the latest version of LabVIEW (2021 SP1) or the currently support FRC version of LabVIEW found here? There are multiple modules that are required to run FRC LabVIEW code beyond what might just be installed with a “normal” LabVIEW install.

Yeah, I downloaded from there. I installed it from that link, did all the steps, but yet when opened, I still got that error. If it helps to know, I had to completely delete everything and reinstall it, though I don’t know if it will, seeing as it was completely removed and fully reset.

Were you able to license everything successfully? Are you prevented from deploying to the roboRIO? If you are and have activated everything maybe you could post what you are trying to open here to see if others have a problem opening it?

Here is a screenshot of my License Manager:

I’m not able to see the roboRIO through LabVIEW, much less deploy to it. That error is showing up and when I right-click on it, I am given only the options to “explain warning” and “remove from project”.

I see you have LabVIEW 2021 installed.
We are not using that, so make sure that isn’t what you started up.

Be sure you are using “NI LabVIEW 2020 SP1”
LV app for 2022

Here is what my License Manager looks like:

When I open up LabVIEW, that is what I run, since the 2021 version isn’t an FRC version. But even when I do, it still shows that target error.
Here are my screenshots of the same you have shown:

Screenshot (3)

Might I need to uninstall the 2021 version? Or does that not interfere with it?

I suspect interference between 2021 and 2020 components.
The safest approach is to uninstall all the LV products, both LV 2021 and 2020, and everything else listed in the NI Package Manager, then reinstall just the FRC 2020 SP1 version & the Game Tools.

Yeah, I was thinking I might have to uninstall/reinstall. At would I have to download the 2022 version it shows or the 2020?

That’s the LabVIEW 2020 SP1 version

Sounds good, I’ll try that. Thanks for the help thus far!

I uninstalled it fully and then reinstalled. I’m still getting the target error from the beginning.

This is happening with a brand new FRC roboRIO Project from the Getting Started templates?

Could you also try a new project from the FRC Dashboard template?

Yes, I tried that from the start to test, and I still get it with the template.

Take a look at the NI Package Manager and compare the versions to what I have in case you can spot a difference.

It seems like I’m missing some packages:

I just followed a guide that one of our coaches had for us to install LabVIEW.

Give me a minute and I’ll throw together the steps I took to install.

Here is what it looks like when I’m going to make a new template:

Sounds good.

The step-by-steps are here: Installing LabVIEW for FRC (LabVIEW only) — FIRST Robotics Competition documentation

I think you should be able to just run the install again and the installer will pick up on things that are missing.

Things to be wary of:

  • Don’t check or uncheck anything from any of the lists that popup during the process. Not all items on the lists are checked, so stay away from the Select All buttons, too.
  • Say “No” to the NI Update Service offer. That would install stuff that hasn’t been vetted for FRC.

Keep an eye out for any error messages that popup during the install.
It looks like your install errored out in the middle of the process. I have encountered errors on some installs and was able to work around them.

1 Like