Labview Joystick Input Example code not working

Howdy All,

For the life of us we can’t get the Joystick Input example code working. We’ve updated the cRio firware to v19, update the driver station code & Labview to the latest versions. We’ve tried every USB port on 2 computers as well as changing the USB1-USB4 parameters. We tried 3 different types of joysticks, 2 of which were working last year.

The default dashboard sees the joystick and acknowledges button pushes.

We’re stumped. The example is very straight forward and simple - can’t understand what’s going on.

Has anybody else tried the Joystick Input example and got it to work?


  • Jeff

I tried to run the joystick but couldn’t get it to work and gave up.

It worked last year. To me, it doesn’t look like it has changed from last years code. Could the way they use RefNum Registry Set VIs this year be something to do with it? Maybe the code has to be modified to use them?

Where in the Dashboard does it acknowledge Joystick buttons? I missed that…


We’re having the same issue. I posted it under title

“HELP!! No readouts anywhere on dashboard”

Have gotten a couple of responses. Take a look and see if any help you guys out. We’re going to try them as soon as I get a programmer in my classroom. Can’t for the life of us figure out what’s going on either.

Best of luck and if we figure out our problem I’ll shoot you a message letting you know what our solution was. Would appreciate the same…:yikes:


Ah! That does make sense. We’ll take a look at the new basic robot code and Extrapolate an example from that.

Much appreciated!

As for the Joystick button press acknowledgement in the dashboard - I forget which page it is on (I think it is the setup page where you can re-arrange the joystick ports). When you press any button, the joystick name changes to a blue colour acknowledging the button press.


  • Jeff


I think Doc Wu is on to something here. If he is correct, it looks like the example code from last year is the same for this year. Some fundamental changes have occured between the two seasons. I would suggest ignoring the example code (at least for the joystick)… and try to build your own example from the Basic Robot Code provided (when you build a new robot project) - the exact name/process escapes me right now.


  • Jeff

I just ran the LabVIEW Joystick Input Example - it worked for me. I have the Driver Station running, and I can read the joystick in Teleop Enabled or Teleop Disabled. A couple things to check:

  1. On the DS Setup tab, do you see your joystick in the Joystick Setup list?
  2. If you click the main button on your joystick, does the text in the Joystick Setup turn blue?
  3. On the DS Diagnostics tab, are you getting any errors?

Now I feel stupid.

I just realized what we were doing wrong. The DS must be running when we run our code (DUH). We never had it running during testing. Guess I need to read the instructions more closely rather than ‘skim’ to the highlights.

See last year we would take for granted that the DS (blue box) handled the joysticks etc… for us. The new DS (laptop) can’t handle I/O unless the DS software is running - which makes perfect sense.

Thanks for putting me on the right track. We’ll give it a whirl tonight.


  • Jeff

Jeff and Doug,

I am going to post this both here and in my thread in hopes of a quick answer. We tried steps and here are the results:

When we run the code and switch to the driver account:

  1. Text turns blue when joystick buttons depressed
  2. Robot code (right below the team number) turns solid green

However…still blinking yellow lights on jags…

Any ideas?


WE HAVE MOTOR RESPONSE!!! Our programmer was reading your posts and banging his head against the classmate and motors and I walked to the back room to check on the mechanical when suddenly I heard motors spinning. The programmer said that there were LOTS of things wrong but had to go to tennis lesson before he could explain. He’s coming back at 9:00 (CST) so will ask him what it was and post back then.


What would we do without Delphi?!:yikes:


Glad to hear you’ve got it working!

Our problem is solved… we weren’t running the Driver Station program during testing :slight_smile:


  • Jeff

In general, this is a bad way to do development. If you want to develop code on the classmate, you should simply run the driver station application from the start menu in the developer account, not switch accounts. If you switch accounts, you can get into a state where it’s not clear to other people on your team what’s running and you will end up wasting time trying to figure out why there is no communication with the robot. If you avoid doing this you won’t risk this wild goose chase.