Labview keeps messing up ethernet settings

Hi all,

I have been teaching myself how to program many of the awesome features in labview, but I seem to have hit a strange wall.

Every time I launch a FRC labview file, the computer changes its Ethernet port settings to the things that labview needs to connect to the robot and it messes up the internet connection at my father’s office. Because of this, I have two questions:

  1. What does labview change in the settings. I have fixed all of the IPv4 settings to what they used to be, but it is still a no-go.

  2. How can I tell labview to stop doing this, and let me configure the network manually when I need it?

Any help would appreciated, even if it is just a pointer in the right direction.

Are you using the FRC 2015 plugin? you no longer have to change your ip to connect to the roborio, you had to with the crio, and even then I dont remember labview doing that.

Do you have anything like NetSetMan installed? That could change your setting on the trigger of labview starting

I have never heard of netsetman
I have only installed the packages from NI. I do not think I can get this year’s files because our team did not compete this year.

If you could at least tell me what is being changed. I could fix it myself. This is my dad’s work computer.

I assume you’re using windows, can you please post screenshots of your “network and sharing center” and “adapter settings” page in control panel before and after as well as the device properties for the interfaces being changed. I have never heard of this bug before and am trying to narrow down what is causing it.

Last time my dad took it to IT (they were not too happy about what happend).

My dad says he just changed the ipv4 settings under the local area connection properties. I changed bto ack to the photo my dad took of the menu and it still won’t work.
The screen shot shows a change in ip address, Gateway, and the dns server address. :confused:
I’m not sure how to attach a photo through the ipad though, will Try soon.

Also, I may have found what is wrong, looks like I messed up entering the gateway address, but no promises.

What I really would like to know is simply how to get labview to stop changing all of these we things. He needs a specific ip address and other things, but labview changes it to, it messes the other settings too. is the correct ip to connect to the robot, the other thing that you need to change is the subnet mask, which needs to be; however, that was for 2014, you dont need to change your ip to connect to the roborio and in my experience, labview doesn’t do that, you need to do it manually

Understood. But it is setting it automatically.
How do I get labview to stop setting it automatically?
If I know that, everything else would be easy.

Im sorry I’m not more help, have you tried uninstalling and reinstalling labview?

Thanks for the help you gave. I hoped I would have to try that. I’ll it give a go

For those of you just reading this thread for the first time. I need to know if anyone knows the fix, and how to apply it.

I will post that this has been solved if I get it fixed.

LabVIEW doesn’t change the PC’s network settings, so something else is doing that.

Are you starting up last year’s Driver Station by any chance?
That actively changed the PC’s network setup to accommodate the robot.
The 2015 Driver Station doesn’t do that anymore either.

I believe that the network settings are being changed by the Driver Station rather than by LabVIEW. What happens is that the DS assumes you launched it in order to connect to the robot. It will check the settings using ipconfig, netsh, and other commands and will offer to change the settings. When it changes them, it stores the old settings in a file called

FRC Restore My Network Settings.bat

This is stored in the Users/Public Documents/FRC directory, and it is a simple batch file that points to a restore file made by netsh the first time the DS ran it.

So assuming this is the issue, you may just need to get in the habit of running the batch file when you are done.

Greg McKaskle

Cool, I have been using the driver station. Any way I can get it to stop or maybe run the batch file when I quit the application?

In the Driver Station:

  1. Go to the Setup
    tab 1. Click on Choose NIC…
  2. Choose** “I will configure my wireless adaptor manually”**
  3. Choose "I will configure my ethernet adaptor manually"
  4. Click OK
  5. Use the red X
    (on right side by the Charts tab) to quit out of the Driver Station application.*]Reset your desired network adaptor settings manually to be what you want them to stay.

This is all old news. You never have indicated what version of LabVIEW or the driver station you are running, but from the evidence, it is at least a year old.

When you provide details it helps people help you.

Oh, sorry about that. It is last year’s software (FRC 2014)