LabVIEW: Unable Install Code (Access Denied)

This might be a really simple fix but I’m on a new team and we’ve been having trouble with getting our code to upload to our cRIO. I downloaded the new LabVIEW program from the USB card and have installed all three of the updates on the FIRST site. I have programmed with LabVIEW 2011 and gotten it to work with last years version of LabVIEW, although, now when I try and upload the code, I get the following error:

“Access denied: This target is running a version of LabVIEW Real-Time that is different than the Real-Time Module software on the host computer. You can verify the version and reinstall the Real-Time software using Measurement and Automation Explorer.”

I’ve looked into MAX and I couldn’t find anything on how to reinstall the latest version of Real-Time. I saw some other posts similar to this on the forums but none specifically pertaining to this error so we’d be very grateful for any help whatsoever. Thanks! :slight_smile:

It sounds like you didn’t re-image the cRIO with the new (v43) image.

I am having a similar problem (I think)
We have the latest image on our robot, but when I try to deploy the code from Labview, I get this error message:

“Access denied: This target is running a version of LabVIEW Real-Time that is different than the Real-Time Module software on the host computer. You can verify the version and reinstall the Real-Time software using Measurement & Automation Explorer.”

The thing is, when I look at MAX, Both my computer, and the cRIO are using Real-Time 11.0 (11.0.0).
I tried reinstalling Real-Time on the cRIO, but it didn’t change anything.

Any help/ideas/anything would be welcome!

There are easy ways to check your FRC versions on both the cRIO and PC LabVIEW installation.

Fire up the Driver Station application, connect to the cRIO and the Diagnostics tab should display the version numbers of the

  • cRIO = …v43
  • DS = 11.30.11.00
    (and Kinect Server version is displayed there, too)

Fire up LabVIEW and verify the version:
Help -> About FIRST Robotics Competition Software…
It should say “Software Update 4.0.0”

Hey,
We are having the same problem between Labview and Compact C-RIO. When I open Labview it says click for mandatory update wheras I’ve done it too many times. And also the version of labview is still 3.1 but Mr Mcleod says it must be 4.0 What am I missing ?? Is there any idea that can help ?

Where is it telling you version 3.1? The actual LabVIEW version is 11.0, so far as I can see.

If you’re talking about the “FIRST Robotics Competition Software 2012” update number, you might not have run the mandatory FRC LabVIEW update. On page 3 of the Getting Started with the 2012 FRC Control System document, it says:
After you’ve installed your programming language base software, all teams must install the language specific updates.

Did you install this year’s labview from the kit of parts? It sounds like you are still using last years version.