LAN fine WiFi inoperable

I have been able to reset and configure my router for LAN use, and can download and run robot code, but only on a tether. The robot’s network will not show up on WiFi. I’ve completed all the 2013 configuration steps and tried the 2012 instructions of connecting to but only got a URL error response. Any help would be appreciated.

Did you run the 2013 FRC Bridge Configuration Utility?
Following the directions at Programming your radio for home use?

The wired side of the router acts as a switch. Doesn’t really care about the IP addresses of the devices attached to it. What is important to talk to the router is your computer needs to be on the same subnet as the router. Router reset to the default configuration & you are talking to the crio–you are on the wrong subnet for the router. You need to change your computer to IP xxx<255 & not 51. Mask should be After you configure the router you will have to change your computer’s IP back.

The default SSID for the router should show up if it has been reset. Dlink as I recall. Make sure the router is in AP & not bridge mode.

Sorry I haven’t responded, I forgot to switch on my subscription. I did run the Bridge Config and followed those instructions, but no success. What do I need to do after changing the computer IP? I changed it to with the Mask and ran Bridge Config again, but still nothing. What is next?

Any more ideas?

The DLink can be set to almost anything and you should still be able to see it’s wireless and connect to it.
For passing IP traffic through to the cRIO, the DLink IP settings don’t really matter much.

The simplest approach is:
[li]Reset the Dlink[/li][li]Set the DLink switch on the back to AP 2.4GHz[/li][li]Set the laptop IP to match your cRIO. e.g.,[/li][li]Open the laptop wireless connections, look for “dlink”, and connect to it.[/ol] [/li]If you want to follow the FRC standard, the DLink settings are:[ul]
[li]Manual switch on back set to AP 2.4GHz[/li][li]WIRELESS NETWORK SETTINGS:[LIST][/li][li]Security Mode: none[/li][li]WI-FI PROTECTED SETUP: Disabled[/li][li]WIRELESS MAC CLONING: Disabled[/ul] [/li][li]NETWORK SETTINGS:[ul][/li][li]LAN Connection Type: Static IP[/li][li]IPv4 Address:[/li][li]Subnet Mask:[/ul] [/LIST]Laptop settings:[ul][/li][li]Your laptop NIC must be compatible with the DLINK, e.g. 2.4GHz and a/b/g/n[/li][li]Your wireless must be Enabled[/li][li]You must find the DLink in the list of available AP connections on the laptop.[/li][li]You must manually Connect to the Dlink from your laptop.[/li][li]Your laptop wireless IP: / netmask:[/ul]You can check the DLink IP settings by connecting your laptop to it via Ethernet and using a CMD window, type: arp -av or ipconfig /all[/li]
To change the DLink settings you connect to it directly via Ethernet.
Then depending on the current DLink IP setting you must give your laptop a compatible IP address,
e.g., if the DLink is at the factory default of, then set your laptop Ethernet IP to,
or if the DLink has been set to the FRC standard, then set your laptop Ethernet IP to

Use any browser and type in the address (or to browse to the DLink.
When you get the DLink login screen just use what the screen defaults to for username/password.

If it tries to put you through the DLink setup wizard just cancel out of it.

It still doesn’t show up on the network, and here’s a picture of my arp -av, but i didn’t see either of those numbers on my LAN.



That looks like you have your Ethernet port is set correctly to and is cabled directly to the cRIO (that’s the address).
You don’t want this Ethernet wire plugged in if you are trying to get a wireless connection to the cRIO going.

It also looks like your wireless connection is set to, so you must change your laptop wireless connection to a static IP address of in order to talk through the router to the cRIO.
The DLink for the robot does not use IP addresses in the range 164.x.x.x, so it looks as though the wireless is auto-connecting to a different nearby router and getting a DHCP address from that.

Cable the cRIO directly to the router.

Lastly, you must search for “dlink” or “3597” on the wireless networks broadcasting in your immediate vicinity. I’ve attached an example of how to look for available wireless networks. On the task bar look for the wireless icon (this one has a yellow marker on it).
If it shows you connected to another wireless network, then disconnect from that first.



I reset the router and the wireless IP address, disabled and unplugged my LAN connection, and also unplugged the connection to the cRIO, so as far as the router knows, it is just powered on for the first time and set to 2.4GHz. It still didn’t show up as either dlink or 3597. Could it be a nameless “Other Network”? I tested those too as dlink and 3597 but they didn’t work either. My computer connected to it last year so I know it is compatible.
Should it show up even if my IP address is bad, and I just won’t be able to pass information on the next work, or will it simply not show up at all unless the wifi computer IP is correct?
Could it be the ethernet cable? I am using patch cables from both computer to bridge and from bridge to cRIO. I’ve been able to connect to the robot and enable it in the driver station though so I don’t believe this is the problem. It seems most troubling that even as a complete reset, it won’t show up at all.

Wireless APs show up in the connect list no matter what your laptop IP is set to.
APs will pass network traffic through for anyone. They don’t really care if their IP matches yours or not.

If it’s the standard Dlink then the factory default is “dlink”.
It should be the one with the strongest signal though.

Are you in a school or at home?
Some IT departments/venues will suppress unidentified APs from broadcasting, but it’s only a possibility.

There is a standard option that hides the AP SSID, but that’s not the default.
You’d have to go set that option on purpose.

You may have a broken Dlink wireless.

Do you have any old AP routers around the house?
You could test with one of those. No changes to the router are necessary.

What does this mean? If you just pressed and released the “reset” button, you didn’t do anything to its configuration. You have to hold the button for a specified amount of time, watching the router’s lights blink, in order to return it to a “factory fresh” state.

Resetting is not just a in-out click, but the full ten second hold. I think you’re right, Mark, the wireless probably is broken. It’s strange though since it’s the same router as has worked last year, we haven’t smashed it around or anything, and the LAN connection still downloads code just fine. The router is at a school, but no one has been able to set the hide SSID option. We don’t have any spares, but we’re all about ready to give up and get a new one.

Just mounted it on a robot and smashed the robot into other robots, walls, …:ahh:


Haha, oh but of course!