libFRC_NetworkCommunication.so.17

After deploying code to RoboRIO and starting driver station, no code light comes on. Communication and Joysticks light OK. Looking at console, the following error repeats. When viewing RoboRIO directory it is found that libFRC_NetworkCommunication.so.18 exists on RoboRIO, but system appears to be looking for libFRC_NetworkCommunication.so.17. How can this be adjusted.

The RoboRIO has been reformatted numerous times. Java does not install automatically with code deploy so it is manually installed via the Java installer. The version is the same that was used last year which seems to be the only option on Oracles website.

Tried renaming the files, but RoboRio doesn’t seem to allow me to do so. Tried downloading and renaming and uploading, but that errored out as well.

Looking for a good idea.

usr/local/frc/lib/’ ‘-jar’ ‘/home/lvuser/FRCUserProgram.jar’»
Exception in thread “main” java.lang.UnsatisfiedLinkError: /usr/local/frc/lib/libwpilibJavaJNI.so: libFRC_NetworkCommunication.so.17: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1929)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1847)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1119)
at edu.wpi.first.wpilibj.hal.JNIWrapper.<clinit>(JNIWrapper.java:22)
at edu.wpi.first.wpilibj.RobotBase.initializeHardwareConfiguration(RobotBase.java:171)
at edu.wpi.first.wpilibj.RobotBase.main(RobotBase.java:194)
➔ Launching «’/usr/local/frc/JRE/bin/java’ ‘-Djava.library.path=/usr/local/frc/lib/’ ‘-jar’ ‘/home/lvuser/FRCUserProgram.jar’»

I’m not a java guy, but this smells like you need to upgrade the toolchain on your laptop. It’s building code which is looking for the 2017 library versions.

You need to update your Eclipse plugins to 2018. Make sure your update site is correct in eclipse (see http://wpilib.screenstepslive.com/s/currentCS/m/java/l/599681-installing-eclipse-c-java#installing-the-development-plugins-option-1-online-install) and check for and apply updates.

When you look at the Help -> About Eclipse and select Installation Details, go to Plug-ins tab and then sort on Provider.

The blank one at the top is "edu.wip.first.wpilib.plugins.core and needs a 2018.x.x (there was an update last Friday?) so your mileage may vary.

Then the two at the very bottom will be for WPI (they have actual providers) should have the same version number (they get installed together).

If you have 2017 - this is what is wrong, not the firmware on the RIO.

Thank you everyone. The plugins were there, but I guess they didn’t take correctly. I was using the same Eclipse as last year with all the new additions. Deleting Eclipse and reinstalling Eclipse and the plugins seems to have done the trick though.

Appreciate the quick and Excellent response.

the eclipse software is the same, but is not the case for the wpilib plugins, so you have to go for help>install new software and install the new plugin with all the other classes, for example the robotdrive have been deprecated this year and after you that make sure the radio and the roboRio is updated with the frc update Suite.