LIDAR Lite v2 not working

We bought the latest greatest LIDAR Lite v2 from PulsedLight and can’t get it to work on our roboRIO.

Searched the Internet from top to bottom and have done all the usual tasks - verified the power supply (solid 5 volts), verified with the manufacturer and supplier that the I2C SDA & SCL accommodate 3.3 v, added the pull up resistors, added the capacitor. Scoped the 5 v power supply line (no glitches seen on a 15 MHz scope). Checked our C++ code every which way (we use WPILib, of course). Tried both the on-board and expansion board I2C ports on the roboRIO.

In place of the LIDAR Lite v2, an Aadvark I2C host adapter simulator communicates with the roboRIO just fine and our commands are seen by it and our program responds to the manually entered responses (that we think will be returned by the LIDAR Lite v2).

We’ve tried everything everyone can think of except we don’t have $2000 protocol analyzer to try.

Anybody get the version 2 of this LIDAR Lite to work?


Suggest you merge with this thread ->

As soon as I gave up all hope and posted my question, the answer appears.

Use WPILib C++ I2C WriteBulk and ReadOnly instead of Read.

Murphy’s Law in action!

Here’s my example program attached (2 files) to acquire the distance using C++ WPILib for January 2015 roboRIO.

Lidar.cpp (9.75 KB)
Robot.cpp (858 Bytes)

Lidar.cpp (9.75 KB)
Robot.cpp (858 Bytes)