LimeLight 2 ignoring settings

So been fighting with our LimeLight for a couple weeks.

First problem I keep running was the limelight start doing this flashing the leds (left side, then right side). Once it started doing this, it wouldn’t process images and I would have to power off and totaly reset.

But when it wasn’t doing it’s flashing mode (which I was not setting). It would send to the NT the tv, ty, tx, ta. I could also set the ledMode, camStream, etc just fine.

But to get it to stop going into the flashing mode where it wouldn’t stream or process images. I decided to update the firmware to the 2020_2.

Flashing mode, no processing of images all good after that.


Now when I try to read any of the tx, ty, any values… I just get 0.0. Even though it has values when I look at the web interface on port 5801.

It also ignores me trying to set modes. Like putting it in Driver mode, or setting the Stream mode.

I’ve gotten these same resaluts reading the NetworkTables myself using the code from lime lights read the docs. Also get the same thing when I used @fearxzombie limelight library

and yes the table trying to read is just the basic “limelight”

So now I’m wondering if I flash it back to the 2020_1 firmware?

Anyone got any other ideas?


I have the same problem! :dizzy_face::triumph:

Also to add.

When I got into OutlineViewer and look at the network tables. I see a table for limelight, and I see the stream, camMode, and ledMode that I’m trying to set. Update with the correct values. But the camera stream never changes.

So I’m very confused.

my limelight code

import frc.robot.limelight; \\ <-- fearzombies limelight library

private limelight my_limelight = new limelight();

\ in robot_init
my_limelight.setCAMMode(0); \\ <-- put cam into vision processing mode
my_limelight.setStreamMode(1); \\ <-- set the PIP so LL2 is big and usb cam is in little right corner


SmartDashboard.putNumber("LimeLight X: ",my_limelight.getTX());
SmartDashboard.putNumber("LimeLight Y: ",my_limelight.getTY());
SmartDashboard.putNumber("LimeLight Area: ",my_limelight.getTA());

if (m_driver.getBumper(Hand.kLeft) == true){ \<-- invert driver control to drive backwards along with cameras
my_limelight.setStreamMode(2); \<-- PIP changes to USB (backwards)
my_limelight.setCAMMode(0); \<–Makes LL more like a driver camera
my_limelight.setLEDMode(1); \<-- Turns LEDS off
m_myRobot.arcadeDrive(m_driver.getY(Hand.kLeft), m_driver.getX(Hand.kLeft),true);
else{ \<-- Driviing normal

\\ Same code as above just inversed to turn vision process on and as the main PIP, leds
\\ on, and invert the driver controls

In the tables i see where Stream Mode, led mode, cam mode get set to new values. But the camera stream in SmartDashboard never changes, also the stream on LL2 console (port 5801) never changes. Also calls to update the smart dashboard with the TY,TX,TA, etc… never change.

Thanks again.

Have you gone to the settings tab on the limelight configuration webpage and set your team number? If not, you won’t be able to see the data from your RoboRio. I also suggest setting your limelight’s ip address statically.

For more info, consult this part of the limelight set up guide:


The team number doesn’t save after you flash new firmware, btw

Thank you so much. I totally missed doing that after I flashed it. I feel about 2 inches tall right now.


The real lesson here is I could have saved myself so much wasted time and headache if I would have just asked for help a week ago. Also read the instructions step by step… ugh.

Thank you again.


Working for me now that I set the team number. You?


Sure thing! I don’t think I’ve ever remembered to enter the team number before trying to test at least once and being confused over the missing values.

I’ll try it tonight. Rrrrrrgh I reset the IP to dynamic and everything how did I miss that!

Glad to see you got it all figured out!

1 Like

Any luck?

yeah, it worked, thanks! next time i’ll have to pay more attention :roll_eyes:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.