Limelight 2+ Setup Issues (SOLVED: Use PoE for best results setting up)

We are setting up our limelight 2+ and we update the imaging to the latest version and when we try to bring it up on the finder it won’t show up. Also will not show up in the “limelight.local:5801” address it tells you to go to.

Can anyone tell us what we could be doing wrong?


1 Like

I had a similar problem. Our team has never used limelight before, and we had just received a limelight 2+. I attempted to use it by plugging the micro USB cable into a laptop, and was successfully able to image it, but was unable to find it in limelight finder or go to limelight.local:5801. Turns out you have to power it with 12v in the weidmuller connectors (or use power over ethernet), and connect the ethernet to either your robot’s radio (second port, furthest away from the power plug) or directly into your computer. When you plug a micro USB cable into it, it only provides enough power to image the device, and actually puts the device into imaging mode.

Hope this helps! -Maze

1 Like

So have the robot on and image it at the same time?

1 Like

No. To image it, unplug the limelight from everything on your robot, and only plug it into your computer via usb micro type b.

We went from having it wired to doing PoE and now it works. Our limelight 2 we had over PoE but we also use our wireless over PoE and we only had one cord. So we unplugged the wireless and used a regular wired connection and used the PoE on the limelight. So weird why just wiring it with a 20 AMP fuse into the PDP doesn’t work.

Not sure that makes any sense to me. So if anyone can explain why it would be doing that it would be great! Thank you @MazeOfEncryption for saving us time because we have been sitting here for 2 hours trying the instructions over and over lol.

1 Like

Just to clarify - do you mean breaker instead of fuse? You should have the limelight wired into one of the 8 20A / 30A Protected Channels on your PDP, not one of the weidmuller connectors on the PDP or the VRM.

Yeah breaker. My bad :sweat_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.