Limelight 2022.2.2 (Mandatory Upgrade, New Features)

Mandatory upgrade for all teams based on Week 0 and FMS reliability testing. Thanks to all of the teams that were a part of this new image.

Bugfixes

  • Fix hang / loss of connection / loss of targeting related to open web interfaces, FMS, FMS-like setups, Multiple viewer devices etc.

Features and Changes

Crop Filtering

  • Ignore all pixels outside of a specified crop rectangle
  • If your robot has any sweet spots for scoring cargo, you can make use of the crop filter to ignore the vast majority of pixels in specific pipelines. This feature should help teams reduce the probability of tracking non-targets.
  • If you are tracking cargo, use this feature to look for cargo only within a specific part of the image. Consider ignoring your robot’s bumpers, far-away targets, etc.

https://thumbs.gfycat.com/ChillyWhimsicalGander-size_restricted.gif

Corners feature now compatible with smart target grouping

  • This one is for the teams that want to do more advanced custom vision on the RIO
  • “tcornxy” corner limit increased to 64 corners,
  • contour simplification and force convex features now work properly with smart target grouping and corner sending

https://thumbs.gfycat.com/DaringTatteredBlowfish-size_restricted.gif

IQR Filter max increased to 3.0

Web interface live target update rate reduced from 30fps to 15fps to reduce bandwidth and cpu load while the web interface is open

https://docs.limelightvision.io/en/latest/software_change_log.html

13 Likes

Tried flashing with 2022.2.2 and was unable to connect to the limelight at the default IP’s and ports. Additionally, the image I downloaded has sdcard.img instead of the standard naming for the limelight .img inside the .zip . I believe the available image is bad because falling back to old image allows me to detect and interact with the standard GUI.

Besides fixing the currently available image, may I recommend keeping the previous image available until the new image is confirmed to be working for the masses.

2 Likes

Hi Ryan,

The link to 2022.1 has been restored, but we have quite a few teams running the newest image now with success. Have you tried using the limelight finder tool?

This one might remain a mystery.

We tried the limelight finder tool, we were able to see it but the configure page could not connect. This includes attempts re-flashing twice to 2022.2. I re-flashed to 2022.1 and flashed a brand new limelight to 2022.2 – able to ping both and configure both. Finally re-flashed the original limelight to 2022.2 one more time and were able to ping and configure.

2 Likes

I’m glad to hear that it is working, but I have noted your experience and will look into the web gui server’s reliability.