Limelight 3 Module not initializing

So I just got our shiny new LL3 and Im runing through the initialization process on balena etcher like usual. I choose the image but when I go to select module its just stuck on module initialization. I dont mean that the blue bar moves slowly I mean it just never starts. After 15 minutes of having it plugged in windows gives me an error saying that the removable usb device plugged in might be corrupted. Does anyone know anything about this?

Have you tried different USB cables? Did you install the USB drivers from the limelight page?

What version is your balana etcher? We had a similar issue and realized we needed to update our balana etcher version.

See Here:


Downloads – Limelight for FRC (limelightvision.io)

Also make sure you download the drivers on the same page like @KH987 suggested if you haven’t already, as well as bonjour.

2 Likes

I think updating the flash tool might do it, I didn’t realize there was a specific version needed for LL3.

I can prune out usb cables/ports as an issue as I have tried multiple of each, I have USB drivers downloaded since like last month do you think that i need to download a newer version?

Probably just a balana etcher out of date issue then.

No, your usb driver should be fine if its from last month.

If updating balana etcher doesn’t fix it, you could try and reinstall the driver, I guess, but I don’t think thats the issue.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.