Limelight does not pick up IP

We just recently got a limelight 2+ and were trying to follow the instructions to configure it. Tried with both the 2022.2.3 and 2022.2.2 images. It is powered through the PDP and the networking is through a brainboxes sw-005. When the limelight is connected via ethernet to the brainboxes switch, the port on the switch never lights up (the other ports that are connected to the radio and the roborio do connect, and i’ve tried connecting to other switch ports as well). On the limelight side, the lights come on, and the lights on the ethernet port on the limelight will periodically flash but not in a discernible pattern. After connecting tried using the angry IP scanner but it doesn’t show any other devices other than the radio, the computer, and the roborio. Tried resetting the limelight as well, but it just doesn’t seem to be getting an IP at all to allow us to configure with a static. Not sure what else to try.

Have you tried using LimeLight Finder? The app can be found on the LimeLight web page and that should be able to show you your limelight image and interface. You could also see about going onto the interface via website when you connect to the robot’s network (10.##.##.11(# being your team number)). We have the LimeLight connected to the same network switch along with our Rio and our Radio, if all else fails I would double check your connections. I am also sure that @Brandon_Hjelstrom can help on this matter

1 Like

Yes I’ve tried the limelight finder.

For the network connections, I have the switch with connections to the roborio, the radio, and the team laptop and have verified that all the devices get dhcp IPs. On the switch I can see the lights flashing that they have network connectivity. The issue is that port that the network cable that’s connected to the limelight never flashes as if it has connectivity. In addition the network port on the limelight itself doesn’t flash like it has connectivity either (though since I have never seen one working, I don’t know what the flashing pattern should be). What I do see on the limelight side with the LEDs is that every so often the green and amber lights may flicker briefly.

The problem that I have seems like the limelight is not picking up an IP address. But I don’t know why, because other devices connected to the switch in the same way pick up IPs via DHCP fine. I know that we want to set it with a static address, but until I can reach it at all I can’t do that.

I’ve tried resetting and reflashing with different firmware but that didn’t seem to help.

If the ethernet port lights aren’t lighting up, then it’s likely not a DHCP problem. Sounds much more likely to be a bad link (either bad cable or bad network port). Is the network cable you’ve used custom made or factory-built? Check the cable for damage/defect and/or try a new one. Has this limelight worked before or is it new out of box? If it has, how long ago? Do the lights work if you plug it in to any other device (i.e. limelight direct to laptop/rio/radio, or to another switch/router port)?

I’ve used all factory built network cables and have tried multiple different cables (ones that work when connecting to other devices). I’ve also tried multiple switch ports.

This is a brand new limelight out of the box, it’s never worked. Just bought it when the newest batch came out in mid-Feb.

What I was trying to figure out is if there’s any way to configure it / test while connecting it directly via ethernet to the laptop - I can’t find any instructions on how to do that.

If that’s the case, then it’s possible the limelight just has a bad network port.

Thanks - that’s what I was afraid of. Was hoping I was wrong!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.