Limelight Feed not showing up in SmartDashboard

We have recently replaced Limelight 1.0 with Limelight 2.5 and ever since then, the limelight feed would not show up on SmartDashboard (despite showing up on the online stream). Also, the values we put ot SmartDashboard(including the horizontal and vertical displacement) show up but aren’t correct nor do they change. We’ve tried using a direct ethernet connection and restarting; we tried power cycling multiple times; we went back to the beginning and newly imaged and configured the network set up again; and we changed the IP address for multiple sources (the laptop itself, the RIO, the radio). Alas, our efforts were left in vain.

Any ideas what on what we’re doing wrong?

Warm regards, Team 2791

Firewall disabled? If not, it was possibly configured to allow the old stream through, but not updated to allow the new one (likely IP or port was different). I always recommend disabling it entirely when offline (i.e. connected to robot or field network)

Using Outline Viewer or Shuffleboard do you see any difference?

The shuffleboard widget picker on the left has a section dedicated to CameraServers, which is where you’d drag the feed in to view.

There is also a separate section visible for the limelight in just the Network Tables section.

If you can’t see either of those, it’s probably some team number problem with regard to having the limelight publish to the proper network table.

We tried changing the Firewall settings and also altering IP and port of the new Limelight and yet it still didn’t work. :confused:

Does it show up in the limelight finder tool?

Not sure if I exactly follow what’s happening for you, but make sure you set your team number on the setup tab in the limelight UI. We missed that on ours after an update and wasted 30-minutes trying to figure out why we could see the UI in a browser, but the robot and Shuffleboard weren’t getting any data.

We found a limelight without team number on Limelight Finder but for some reason, the IP address was different from what we set up as our Static IP in limelight:5801

We fixed it: we reverted back to an older image and re-tried the whole set up. Now, we got the stream on SmartDashboard and values.

What version did you downgrade to? We’re having a similar issue where we’re able to access the web UI but not the stream or network tables.

Is your RIO updated to the latest one? We downgraded to last year’s image on the limelight but when we updated our RIO we were able to use the latest version with no problem.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.