Limelight: in the pit, is it possible to access webpage? (http://limelight.local:5801)


At week 1’s competition, we wanted to fine-tune our Limelight’s vision pipeline (not GRIP) [version 2019.5.1]. We tried to access the webpage for the first time in the pit. We were never able to access it, even though it was accessible the night before at home using WIFI, but in the pit, only USB cable is allowed, and the browser (Chrome) kept saying the page didn’t exist.

Note: Our limelight was correctly set with the right team number and with our vision pipeline parameters. We were even able to see the static IP stream (10.XX.XX.11:5800) during matches with the real FMS. But nothing works with the webpage. We tried both http://10.XX.XX.11:5801 and http://limelight.local:5801, nothing…

Thank you!

You can connect to your robot over Ethernet via the radio in the pits. There is no rule that requires you to connect to the roboRIO via USB.

1 Like

Presumably, you need to dual home your laptop, you can have network connections to the 172.x.x.x network via USB, and ethernet simultaneously. It’s just important that you setup routing between the interfaces so the two networks can see each other. We haven’t done that, but theoretically it’s possible.

The much easier solution is to just have a long ethernet cable, if you’re using a limelight connected to the radio as well you’ll want to bring a network switch (or hub) to expand how many ethernet ports are available.

So in that scenario your network setup would be:

Ethernet Roborio -> Radio
Network Switch -> Radio
Ethernet Limelight -> Network Switch
Ethernet Laptop -> Network Switch

Then you can easily access the limelight in your pit.


Amazing! We’ll give that a try.
Thanks @NewtonCrosby

Thanks for the suggestion.

Since the RoboRIO + Limelight completely filled the radio’s ethernet ports, and we didn’t have a hub at the time, we couldn’t try the ethernet cable route. But now, looking at the docs again, it may not be necessary to even have the RoboRIO in the loop, so next we’ll also try connecting our laptop directely to the radio.

If you don’t need the roborio to tune up the Lime Light then unplug the Rio and use that port to tether in. When the issue arises is on the practice field or tyring to see how the code my react to the data your device is publishing.

1 Like

I’ll try that, thanks!

That worked! I was able to access the webpage by connecting laptop in place of roboRio to the radio as you suggested.

Great, It gets tricky if you want to view the NetworkTables and push/pull data to/from the LL over networktables. Then a network switch is necessary.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.