Limelight.local:5801 is not found


#1

We just bought the limelight and it arrived but as we went to set it up we wired it according to the setup steps by installing bonjour and updated its firmware to 2019.2. However, as we try to open up limelight.local:5801 the page is unable to open and we can’t seem to find a way to get past the problem. Has anyone else had this problem and solved it?


#2

We had the same issue and after contacting Greg through email, he suggested we re-image it. It had to do with the micro usb still be hooked up the next time it was powered up.

After we re-imaged it, it worked.


#3

We at 3630 are having the same issue.
The workaround for us was connecting a mobile phone to the radio and using the app “fing”.

The app will sniff all the IP addresses and we found it by trying all the IP addresses “10.36.30.67:5801”. It would be nice however to find a better solution.


#4

Have you tried to turn off the WiFi on the computer? Also is the amber light blinking on the limelight? My team 3244 has been beta testing limelight since v1 and can help with any questions you have. We also have some videos of unboxing and setting up the limelight. https://youtu.be/YHu9EHL_kSQ Also we can help with almost all limelight questions. Email us at granitecitygearheads@gmail.com


#5

@SMSLittle Sorto off topic but out of curiosity where does the ethernet plug into? the RIO? and if so where does your radio plug in?


#6

The Ethernet either plugs directly into the radio or a network switch.


#7

Network Switch connected to what?


#8

So Im assuming both ethernet ports on radio are consumed correct?


#9

One of the ports of the switch would connect to the non roborio port. Then you would connect the rest of your network stuff to the switch


#10

And with no switch it would be 1 port on the radio to rio one port to limelight. Correct?

Thanks for your help!


#11

One helpful tip. Always have a network switch with your robot. It will help you connect to your robot on the practice field of competitions as well as in the pits via Ethernet AND access the camera at the same time.

Back on topic, have you been able to connect to the Limelight.local:5801? We still can’t get it to work.


#12

Can you connect to roboRIO-####-FRC.local? where #### is your team number? If not then you want to use the network troubleshooting steps. You may find it’s an issue with the mDNS responder. We had to install labview to get mDNS responder to work with the above address, then it worked with the limelight. This was before kickoff though, so I’m not sure if the same would apply with the NI update this season.


#13

I finally got around to flashing our LimeLight to 2019.2. I had no troubles until I set the IP to Static. Turns out I Simply closed all my Chrome Browsers and reopen Chrome. Lime Light Connected just fine. My setup here is just a Windows 7 pro PC and LimeLight on a 2amp 12Vdc wall wort power adapter. No Robot, No Radio.

One Thing I like to do is to set my PC IP to Static 10.TE.AM.2 This way I can run the OutlineViewer in Server mode and look at the data published to the networktables with out having a robot. JUST BE SURE TO CHANGE THE IP or SET TO DHCP before reconnecting to a robot. You will have more troubles then if not.


#14

I don’t believe we have been able to connect to Roborio-3322-frc.local but have been able to connect to 10.33.22.2 so does that mean our mDNS responder isn’t working?


#15

We had this same issue yesterday, it was eventually solved by plugging the limelight directly into the computer using ethernet, and then going to http://limelight.local:5801


#16

10.xx.xx.xx would be your connection to the robot via WiFi. 172.xx.xx.xx would be your connection via an Ethernet cable. Our network wasn’t allowing .local addresses when we were connected to the robot via WiFi or Ethernet. Installing labview solved the problem because NI includes mDNS responder in its software install. At least, it did as it December.

We are in Windows 10 and Bonjour didn’t solve it for us. Only the labview install.

I would debug by working to get the roboRIO-####-FRC.local to work. Then try limelight.


#17

Sorry I’m asking for a lot but could you provide a link to the correct NI installer page. The one that you guys used that worked.


#18

Hi. After resetting the Limelight to a dynamic IP, I have been unable to connect to my team’s Limelight at limelight.local:5801, wired to the robot via the radio or connected directly to the computer. I have the Limelight on the newest firmware and have Bonjour and the 2019 Update Suite installed. I don’t know if I have been doing it incorrectly but IP scanning has been inconclusive and reflashing the Limelight has not helped.


#19

We had issues connecting to limelight.local:5801 when using a USB pc->rio connection. The issue went away when we connected to the robot wirelessly, for anyone trying to use USB connection.


#20

We ended up fixing the issue by switching computers and doing a direct Limelight to computer connection to change to static IP.