Limelight new image

We are trying to install the new 2023.0.1 image of the limelight onto the limelight but we keep running into errors. Our ‘flash’ is always failing and I have followed all the steps to download the needed software on the documentation. Has anybody else run into this problem?

1 Like

How is it failing? Do you get an error message? Specifically what steps are you doing?

Pictures are worth 1000 words

One common issue is the cable being used. Make sure it is one that can actually transfer data and is not just a power cable. Also make sure you install the driver’s off of the limelight website. Hope this helps!

1 Like

so, i ended up re-imaging the limelight back to the 2022 version and the flash was successful. however, i am not able to see the ‘settings’ tab on the left of the limelight finder interface.

1 Like

the cable that we used was one that could transfer data as well!

That isnt the limelight interface. This is the limelight finder. You need to click “Configure Selected” on the limelight you want.

1 Like

What Image was on the unit before starting? I had Two LLv2+ last night giving me fits. They had PhotoVision on them before I started. When I first loaded 2022.3.0 the Burn completed. I then confirmed I could get to the dashboard and configure them properly. After that the 2023.0.1 firmware worked.

I had two units that did this in a row.

The other issue I did have and that may have been a condition of a bad burn was balena etcher not detecting the LL. When that happened I closed

  1. balena etcher
  2. unpluged the LL
  3. Then lanced rpiboot
  4. after rpiboot found the device I flashed them with the steps above.

Okay, when we selected “configure selected” it says the limelight wasn’t found (web timed out error) even though the limelight finder detected it and the limelight could also be pinged. Do you know why this could be happening?

We had the 2022.2.2 version before. The 2023.0.1 was the version that failed during the flash.

What is the IP address shown in limelight finder (and/or your browser after clicking configure), and whats the IP address of your PC (open CMD and type “ipconfig /all” then look for the right interface)

If they’re not in the same subnet, the browser won’t be able to connect. I believe Limelight Finder uses mDNS to find it, which uses multicast to discover devices


^That’s the IP of the limelight


^is this what you mean by the right interface?

Yup exactly, except that one os for wifi. You should have another interface in the ipconfog output, likely labeled “ethernet” or something like that. If you turn wifi off and re-run that command, it may be easier to find.

When you do find it, compare it to the IP of your limelight. If its not 10.51.90.*, then that would explain why you cant connect to it. Based on what I see in Limelight Finder, im going to guess it’s 10.51.90.200, but good to confirm.

I am currently not near a RoboRIO right now, but from testing yesterday I can say that my IP address was 10.51.90.2*. I tried flashing the Limelight again today after executing rpiboot and the flash was successful.

However, I got this error message


Is it okay if I click cancel?

That’s normal, just ignore it. It’s what usually happens when flashing a Raspberry Pi image on Windows.

Thank you so much! Our limelight works now!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.