Limelight not connecting

My team (1671) is currently using two bots, both of which have a limelight 2. We were able to use http://limelight.local:5801/ to connect to both of them when we connected to the robot wifi, but not the newer robot (9671) can’t connect. I think it’s because I went to the settings and switched the ip from 10.16.71.11 to 10.96.71.11 thinking that it would solve another problem, but after that change I can’t even get the camera feed, and the http://limelight.local:5801/ link just says “site cannot be reached.” The 1671 robot’s limelight still works fine though. Does anyone know how to fix the 9671 robot’s limelight? I already tried resetting the limelight (with its reset button), power-cycling, and using another laptop.

You should try the actual IP of the limelight. Limelight.local doesn’t work for us either. We have to use 10.36.47.49:5801 and 10.36.47.105:5801

If ur having to use anything other then 10.xx.yy.11 that means you didn’t set your static ip address, which is highly recommended.

@VincentWang001 If you can’t figure out the issue, then you can try completely reformatting and re flashing the limelight and starting from step 1. That should fix any issues (unless its somehow hardware damaged) .

Follow the instructions here to reimage the limelight: http://docs.limelightvision.io/en/latest/getting_started.html#imaging

And after that, these instructions to properly configure the limelight’s ip: http://docs.limelightvision.io/en/latest/getting_started.html#networking-setup

The IP is definitely static, I think something’s wrong with the DNS. Talking about limelight (10.36.47.105 for 1, .49 for the other) not the roborio address

The mdns doesnt matter if the ip adress is static. A limelight is highly recommended to be set to a static ip of 10.xx.yy.11.

If you can access your limelight’s dashboard from any ip adress other then 10.36.47.11, that means you either didn’t configure static ip, or didn’t do it properly. (And since you are saying that you sometimes have to use different IP’s to access the limelight, then it definitely isn’t configured to be a static IP.)

Look at the networking section of the Limelight docs (linked in my previous post) for instructions on how to do so.

It’s two different cameras (on the same robot), not one with two IPs.
I didn’t really bother checking it after it said static on the limelight dashboard.

1 Like

ahh gotcha, I misunderstood

I just tried it today, without changing or doing anything, and the problem disappeared. The limelight’s working like it always has, which is great, but I have no idea why it worked when nothing changed. Do you have any idea as to why it worked and if it might spontaneously have the same problem? Thanks for you help!