Limelight, problem with getting tx from network tables

Hello, dear fellow programmers;

We currently have a problem with getting the value (Tx) from a lime light via network tables.

If anyone is wondering, it outputs as 0.0000 on shuffleboard and smart dashboard

It does that when it doesn’t find a target. You’re probably fine.

You might want to be checking for tv (whether a target exists or not). Here is the complete NetworkTables API.

1 Like

The thing is:

  1. I tried to output the camera into Shuffleboard, and the only result was a black screen (will add in images soon), but however the Limelight’s site at http://10.TE.AM.11:5801 and http://limelight.local:5801 both show camera output as well as tracking a yellow ball we are using to test with. (Code to capture the video from the camera and input it into dashboard)

Sounds like your team number might not be set in your limelight. It uses that to know how to talk to network tables. You’re almost there!


Hey Louis, we tried your advice for checking for Tv. However it doesn’t seem to appear even if we place the target in front of the limelight. On the limelight (,limelight.local:5801), the Tv and Tx are shown properly on the UI, however when we call from network tables, it does not seem to want to display… Any suggestions?

Our team number wasn’t set in the Limelight as you mentioned, but even after setting it, it still refuses to output the camera to Shuffleboard:

Me and @a0wn have been at this for about 5 days and we still haven’t found a solution.
I visited the link that I put in LLFeed, and it works.
Looking forward to hear what you think is the problem, thanks in advance.

Does your shuffleboard have the limelight table accessible?

In (I think, don’t have the robot here to verify) in the widget that pops out from the left, possibly named LiveWindow, it will display all the possibly values that can be dragged out onto the shuffleboard tab.

The limelight table is in that list, you should be able to see if tx, ty, etc are all dynamically updating.

The limelight mjpg stream is also at the limelightip:5800 if you want to see the stream directly.

In the code that we’re using, the Tx, Ty, and other values are being printed to Shuffleboard, but unfortunately, the values are not updating. And what do you mean by “Shuffleboard having the limelight table accessible?”
Here’s a picture of what the shuffleboard values look like: (ignore Red, Green, Blue, IR, and Proximity: those are from the Color Sensor)

Hey @Riftiro and @a0wn,

You shouldn’t need to write any code for the camera stream (or any of Limelight’s output) to appear in Shuffleboard. Here are a few things we can check:

Does your Limelight’s team number (top of the settings page) match:

  1. The team number you set in your VS Code project?
  2. Your Shuffleboard preferences?

What IP address are you using for your Limelight?
Have you flashed with the 2020.1 image?
Is your radio firmware updated?


  1. Both VS Code and the Limelight settings are set to our team number, 369.
  2. Didn’t change any preferences in Shuffleboard
  3. IP is, which I confirmed works
  4. 2020.1 Firmware has been flashed for the Limelight
  5. Our radio is unable to update, but it receives and sends data.

Your limelight table in your image should have a lot more values in it. Ours, at a minimum, has the variables that you can see as you’re calibrating (tx, ty, ta, tv, etc). Just by viewing the table in the pane on the left you should see more.

Sorry I can’t show you screen shots, won’t have access to the robot until tomorrow. Make sure that shuffleboard is properly calibrated for your team. For example, in a subsystem periodic method (or robotperiodic) can you put a double on smartdashboard and see it update in the widget?

Hi, we are not able to find any limelight values in network tables but are getting video feed in browser, only thing is it’s a black screen, I posted earlier.

We can see values updating, as the color sensor gives an output.

We diagnosed the problem down to not getting any network connection within the robot code, but we can get connection to a browser.

Hope anyone can help us out to get network tables properly configured through the Robot Code, thanks in advance!

1 Like

The problem has been resolved, it seems that updating the radio fixed the problem… we are idiots lol



We are having issues with the LimeLight-2 2020.x firmware image as well, and do no get data via NetworkTables with a valid target in view. When we flash the 2019.71 image on the LimeLight-2, everything is working FINE.

We are able to access the Limelight via the browser on port 5801 with all firmware loads, and able to see the target, and see the tx/ty/ta/tv values in the browser.
The tx/ty/ta/tv show up correctly only with the 2019.71 image via NetworkTables.

Team number is set correctly in DriverStation, roboRio, etc.

Current setup:
Laptop, roboRio and Limelight-2 all connect to a switch (no radio for off-robot testing).
All have IPs configured on 10.TE.AM.x (Limelight on .11)
roboRio has 2020 image.

Any thoughts or suggestion to try and fix?
Reached out to LimeLight as well for support.

Thank you.

Hey, the problem is back again… The Tx displays perfectly fine on the site and network tables on Shuffleboard. This might be an issue with the code, since I don’t think there are any other variables. Here is our code:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.