Limelight Restarting

Ever since the start of the season, we’ve been encountering issues with our Limelight 2. We have the Limelight connected directly to a 30A breaker on the PDP and the ethernet is connected to a network switch (we’ve also tried connecting directly to the radio with no avail). Seemingly randomly, the Limelight reboots itself (we lose connection to the Limelight and the LEDs flash). It even happens when the bot is disabled, and we have tried replacing the Limelight with another but it continues to restart. We opened up the Limelight and there was a buildup of the yellow dust from shooting the balls, but removing the dust did not fix anything either. We’re running the latest firmware version (2020.3), and have tried reimaging it as well.


For reference, here are the vision pipelines we are using:

We are experiencing a similar issue as well with the 2020.2 firmware on both Limelight 2 and Limelight 2+

I thought that was just because our connection was not solid. We have this problem too. But it happens to us when we are enabled. Never yet, have i caught the LL reboot when disabled.

Happening to us also.

For us it happens too when we are disabled.

We are seeing this/a similar issue if we are powering our Limelight 2+ over a REV Robotics POE Injector. Either it freezes and doesn’t recover or restarts.

Can confirm, it restarts randomly sometimes, can see the whole LED boot sequence happen out of nowhere. It recovers very quickly though.

1 Like

+1 here. Both our LL2’s are doing this. Happened twice during matches week one.

Happens with both of ours too. I wonder if it has to do with the pipeline or wiring situation. How are you powering yours?

We have it VRM powers Radio, Radio ethernet to LL, LL power lines to PDP.

Has anyone contacted limelight support? What did they say?

1 Like

As an aside : You should probably switch out the 30A breaker for something smaller. The max that the LL suggests is 20A.

Actually the max that limelight suggests is “etc”

1 Like

So thanks to 1410, we were able to stop the Limelight from restarting. We had to disable the Limelight from streaming to the driverstation, and we went an entire day at the Utah regional without having it restart (thanks again 1410). Instead, we relied on the status LEDs on the back of our robot to know when we were aligned.


We encountered in a little different scenario.

We tried to connect Limelight 2+ either through swtitch or directly to the router,
After some time that the robot is running, the NT values from Limelight freezes in LabVIEW despite you still can see stream and updated values in the web interface.

Restarting the Limelight as well reebooting the Roborio solve it temporary, but it’s not a workable solution during a match.

I heard another teams experiencing this issue, has someone managed to figure it out?

We also tried running our own vision processing in a RPI coprocessor, and had the same problem.
It’s never happened to us last year, so we suspect
in this year update to the NT Server in the Roborio.

Although I’m suspecting the NT version of the Server, one of the programmers managed to bypass it by going back until 2016 version of NT in the Client (RPI).
A lot of changes have been implemented since than in NT, so we don’t want to go with this solution.

I don’t want to exploit this thread, so if you’re having the issue I’m describing you can see this Network Tables values of Limelight/Vision Processing freezes in LabVIEW .

What I meant by that was that we were displaying the live camera stream from the Limelight on our driverstation laptop, which was hogging bandwith.

@JLiu @siddharthjain03 @Aaron_Li @nmatthes @qhdwight @flamespinner @SoProTheyGoWoah @Bochek

Thank you for all of the information you provided about this bug. There was indeed an intermittent 2-4 second crash that could occur while viewing the stream. We were able to find a reproducible case in LA, and we now have a fix with 2020.4:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.