Limelight v2 LED problems with PhotonVision

Good evening to all,

We were hit with an unfortunate series of issues with lighting up the full LED array of our limeLight with PhotonVision. When we test our camera view on PhotonVision, only half of the limelight LEDs turn on. The list of things we have already tried includes:

  • flashing the limelight with multiple versions of both the limelight and gloworm software

  • switching limelights

  • switching and importing config files

We were able to get the limelight to work with PhotonVision when we loaded gloworm software onto it, but only half of the led array lit up. When we loaded the limelight with limelight software, we couldn’t get it to work with PhotonVision.

We want to be able to use the limelight with PhotonVision because we have noticed much better target selection and rejection with PhotonVision, but we would like our full led array to shine so we can operate the camera effectively at far ranges.

Thank you in advance!

The Gloworm image is the correct one to upload to use PhotonVision on a Limelight. Yes, that is somewhat confusing, but as they are nearly identical internally, this is easier than us making and maintaining a separate Limelight image.

Can you confirm which Limelight model you have?
The pins that the LEDs are attached to differs between models, so you need to upload the correct hardwareConfig.json for your specific model.
Also, be sure that LED brightness is set to 100%, as on the LL2 (non+), only one side is able to dim.

We have checked that the LimeLight type we have is, LL2, and we also imported the correct hardwareConfig file. We also have checked the camera settings and we set the LED to 100%. The issue still persists where only one side is lit up of the limelight.

And if you flash the original LL firmware, does the second set of LEDs work again?

Yes it does but, the page to our camera on photonvision will not open up, so we’re stuck using the limelight software, however, our goal is to use the photonvision software with a full functioning limelight.

Well with the Limelight image, you can only use the Limelight software, not PhotonVision. The entire contents of the device are wiped clean when you re-image it.

Can you download the settings.zip from the Settings page on PhotonVision, and send that here?

Okay, will do by tomorrow.

Update: We got both sides of the LimeLight to work.

Solution: Downloaded the most recent Gloworm image (Gloworm_Release_3_image), instead we had been downloading the Gloworm_Release_2_image, where only one side of the limelight worked. We also ran into a problem of connecting to the limelight through photonvision, but a simple Network Analyzer allowed us to scan the IP address that our Limelight was broadcasting, which somehow changed through our many trials of flashing.

6 Likes