Linking WPI Library and Eclipse

I am working on trying to link the WPIlib Library to Eclipse, and am running in small circles.
I am using Eclipse 64-bit on a Windows 7 64-bit machine.
I have the FIRST C++ Tools installed.
The latest Java has been installed.

I have tried to install it the recommended way of downloading it from http://first.wpi.edu/FRC/roborio/release/eclipse/ through eclipse, and I always get the smaller of the 2 attached screens as an error message. This message is supposed to be when Eclipse cannot connect to the internet, but my computer is connected, Eclipse can load web pages, I shut my firewall down, and still it doesn’t work.

I have also tried manually installing the library and I get the larger of the 2 attached screens as an error message.

I cannot seem to find the problem.

Is anyone else running into this problem? And does anyone know how to fix it?

Thank you for taking the time to read this enormous post. No programming or software problem is ever simple to describe.

Untitled.png




Untitled.png

Have you tried installing the 32-bit version of Eclipse/Java?

I’m going off of this thread: http://www.chiefdelphi.com/forums/showthread.php?p=1420392

but it seems a resolution has not been reached (OP hasn’t posted about it).

I’m seeing very similar behaviour on one of my laptops. Just so happens it’s the one I normally use for programming. I’ve gotten it to work on another machine, but I’d much rather prefer to use this one. :slight_smile:

So hey you’re not alone.

Thank you for your responses!

I didn’t fix the problem on the original computer, however; we did get the 32-bit versions to work on a 32-bit Vista computer though. (I don’t know how, the likelihood of something working better on Vista than 7 is pretty far out there.)

I will give the results when I get everything finished on a different Windows 7 64-bit computer, but I’m gonna go straight to the 32-bit versions. I be back.

Alright, I got it to work on a different computer. Something must just be wrong with my computer.