LINUX Users: Requesting beta testers

Hey, I need some users of RPM distros to test releases of the IFI Picloader. I’m planning to release some X / GTK+ graphical versions of the picloader, too, so I’ll definitely need people making sure that they work!

I wouldn’t mind testing. Where/how do I sign up?

I’m not on an RPM distro (gentoo), but I’de still be happy to test things and such.

http://sourceforge.net/project/showfiles.php?group_id=98989&package_id=106064&release_id=279618

RPM distro users, I need feedback on the .rpm linked above. Does it work? It should install picloader and picreader in /usr/bin. File bug reports at http://sourceforge.net/tracker/?group_id=98989&atid=622745

wun, if you can patch the Gentoo ebuild, that’ll be great. I’m very short on time here; iIt’ll need the patch removed, new digests. If you can tar up the portage overlay and post it on http://sourceforge.net/projects/adambots-live in the “Patches” tracker, that’d be great!

Also, I’d like your opinions. I want to release RPMs/Debs for mcc. There are a number of ways I could do this:

(1) Package them, then host them on Sourceforge with a licensing disclaimer (though C-Bot’s license agreement is non-existant)
(2) Write scripts that’ll take a Windows pre-installed mcc18 tree and package them, on users’ PC’s.
(3) Write scripts that can take the C-Bot executable and repackage it. This is most certainly the most complicated approach for me…
(4) (3), but with the extra merit

So which will it be?

(1) has some licensing issues, but no concrete, black-and-white issues that I can see.
(2) Is simple to do – it is fast for me to write, but it requires users to have a copy of Mcc18 and Windows installed, which is not always a pretty assumption. Plus, it now has to go finding and mounting Windows partitions, which users often will not feel comfortable with!
(3) Is complicated for me to do. the EXE is a sfx zip, so it’s pretty easy to unpack. However, it has no directory structure, and all the filenames are in caps.
(4) is the hardest… I need to figure out what this “demo stamp” is that the trial EXE looks for.

(2-4) would install like how Macromedia Flash and ms TT core fonts do under Linux: The package is virtually empty, and it fetches the contents on-the-fly.

I’m up for beta-testing ebuilds here on my Gentoo box, I’m sure some of my team mates can help you test debian packages if you have any.

PM me here, or email me at mattkrass AT gmail DOT com.

I randomly have Suse 9.0 or Fedora Core 2 installed for testing RPM installations of my own stuff. I can test your stuff as I get a chance.

Great job. The RPM installed flawlessly on my SuSE 9.1 installation. I have not had a chance to test its functionality because I don’t have a controller to test it on. I did discover it waits indefinitley if a controller isn’t connected (or until Ctrl+C is pressed)

Ok, thx for the feedback.

I released 0.4.97 (0.5 beta 1). No new code; just the output was changed to be friendlier to upcoming frontends (First display total # commands to issue, then display the command number. Good for progress bars).

No reason to upgrade, really.

Also, I imported everything to CVS.

http://cvs.sourceforge.net/viewcvs.py/ifi-picloader/

Not sure if this helps but I compiled and ran the source on my gentoo machine and it worked fine. :slight_smile:

I hate to dredge such an old thread up, but why isn’t this in portage yet?

No real relevance to Gentoo; too small audience.

Looks like you guys took the robot code makefile out of the tarball.

Oh, and the new MCC18 compiler installs through WINE without any trouble at all. I suspect a native msvcrt is still required to actually run the compiler, but installation doesn’t require it.

I’ll post a makefile for this year’s default code ASAP…

  1. Yep. I’m releasing that separately. I have the latest FRC2005 makefile with my FRC Subversion repository:https://jdong.homelinux.net/first/trunk/Makefile

  2. Yes, it does. And if you symlink it properly (symlink $x.exe to $x), you’d NEVER need native MSVCRT.

I’ve made a fix to the built-in msvcrt, but unfortunately, my WINE installation is b0rken right now, so I can’t test it. If you don’t mind, can you apply the attached patch and see if this works? This makes it do a proper search for executables so the symlinks shouldn’t be necessary. If it works, I’ll push it upstream. This patch is diffed against cvs, but it should work on the last release, I’d imagine…

spawnve.patch.txt (1.06 KB)


spawnve.patch.txt (1.06 KB)

For someone who has just come across the linux/FIRST/IFI stuff, could someone give me an overview of all of the programs/patches/etc out there for FIRST and linux. Also, I assume that you do not use MPLAB, instead writing in your favourite linux application and then using C18 to compile?? At any rate, I would like to lose windows this year so, a brief runthrough?

You need 4 things:

WINE - http://www.winehq.org/ - This is needed to run the mcc18 compiler. Try to get it to run solitaire before trying MCC18.
MCC18 compiler - A link to d/l this can be found on the FIRST website.
IFI-Picloader - http://sourceforge.net/projects/ifi-picloader/ - Not to be confused with IFI’s loader, this allows you to use linux to upload the code compiled by MCC18.
Makefile - Grab the makefile that was linked to earlier in this thread. Edit it to taste. This is needed to automatically compile and link everything together.

Probably because no one has submitted it. Post it on the bug tracker and assign it to someone, you’ll need to probably become it’s maintainer, but someone needs to do it. :slight_smile:

Ok,

I tried the .rpm, and it says:

error: Failed dependencies
root@slax:/mnt/disc0part1# rpm -ivh ifi-pictools.rpm
error: Failed dependencies:
ld-linux.so.2 is needed by ifi-pictools-0.4.97-2
libc.so.6 is needed by ifi-pictools-0.4.97-2
libdl.so.2 is needed by ifi-pictools-0.4.97-2
libgcc_s.so.1 is needed by ifi-pictools-0.4.97-2
libm.so.6 is needed by ifi-pictools-0.4.97-2
libstdc++.so.5 is needed by ifi-pictools-0.4.97-2
libc.so.6(GLIBC_2.0) is needed by ifi-pictools-0.4.97-2
libc.so.6(GLIBC_2.1.3) is needed by ifi-pictools-0.4.97-2
libgcc_s.so.1(GCC_3.0) is needed by ifi-pictools-0.4.97-2
libstdc++.so.5(GLIBCPP_3.2) is needed by ifi-pictools-0.4.97-2

What all packages are required for the ifi-picloader

By the way, wine worked for me for C18, but it took three tries.