ListenTo this.

You can now have what song you are lisetning to automatically appended each and every time you post something on the forums.

You need Winamp3, and a little Maki script I wrote, called ListenTo.

go here for details & instructions

It will append the song name when replying and posting new threads. It will not change when editing.

It only will show a song that was recorded being played in the past 4 minutes. (time subject to change)

If you’d like to make something like this for your favorite mp3 player, send me an e-mail, and I will give you all the information necessary to make it happen.

Yes, there will be more website-side features, but its 3:30am… yikes.

are you going to be really cool and make the source for the maki and php script available? cause this would be cool for many sites, with due credit of course :slight_smile:

How do I put this in my signature? It’s not working for me.

*Originally posted by Trashed20 *
**are you going to be really cool and make the source for the maki and php script available? cause this would be cool for many sites, with due credit of course :slight_smile: **

Eventually, yes.

I have to take out the hard-coded URL in the script, so that other people can use it.

That will happen next version. :slight_smile:

Anyway to make it work for winamp 2.8x?

A plug-in will have to be written for Winamp 2.x, if you want it to work.

I don’t plan on doing a 2.x version. If anybody is interested, I will tell them what all is required to be sent to the URL to make it work correctly.

Same with any other media player.

For all you Mac users: I have an AppleScript I may try to modify, so this will work with iTunes. We’ll see.

Is this just random and it puts it in only sometimes? I’ve posted about 4 times since i’ve been using it and none of them have showed up…

Anyone wanna help me out?

oh ya…if i look under my history it puts

(fixed)
Could it be that i’m editing the xml thingy wrong?

*Originally posted by Clark Gilbert *
**Is this just random and it puts it in only sometimes? I’ve posted about 4 times since i’ve been using it and none of them have showed up…

Anyone wanna help me out?

oh ya…if i look under my history it puts

http://www.chiefdelphi.com/forums/postmp3.php?USER=Username%20Here&PASS=123123_brandon_was_here&ARTIST=Alien%20Breed&ALBUM=Visit%20alienbreed.com&TITLE=Crackling&GENRE=Alternative&YEAR=2001

Could it be that i’m editing the xml thingy wrong? **
I think you forgot to put in your CD username… instead of saying USER=Clark%20Gilbert it says USER=Username%20Here

But the XML says

<container id=“CDBrow” name=“Browser”>

<layout id=“normal” drawbackground=“0” desktopalpha=“1”>

&lt;layer id="move" x="2" y="2" image="CDBrow.move"/&gt;

&lt;text id="cdUSER" default="Clark Gilbert"/&gt;
&lt;text id="cdPASS" default="PASSWORD REMOVED BY BRANDON :)"/&gt; &lt;--i was wondering about that :D (fixed)-clark

&lt;browser id="brow" x="0" y="0"/&gt;

</layout>

</container>

It works like this:

Song plays and Winamp MiniBrowser opens a URL (out of sight)

In the next 4 minutes, any post on the forums will contain that song. Unless of course, another song starts – in which case that song will show up (for 4 minutes).

I will be making a page on here soon, to show your last 4-5 songs … and what you are currently listening to. So, if you post, and nothing shows up – you will be able to go to that page and see if a song was recorded in the past 4 minutes.

So, I don’t know why yours is randomly not showing up. I’ll make that page right now, so we can make sure stuff is recording properly. :wink:

Oh yeah.

The following are required for the song to be logged:

  • username
  • password
  • title (id3)
  • artist (id3)

That could explain why some songs are not being logged.

Yay, the winamp script is working though the 4min thing makes it so the song doesn’t register sometimes.

just a thought but is it censored if you are listening to a song with “bad” words in the title? I’m not planning on listening to anything like that but im interested b/c its a mistake someone might make.

*Originally posted by Brandon Martus *
**
Yes, there will be more website-side features, but its 3:30am… yikes. **

Look up in the ‘Site Navigation’ drop-down. I threw an item up there so you can see some ListenTo stats.

Or, go to http://www.chiefdelphi.com/forums/mp3list.php

More may be added, thats all I got for now. Time for some TextTwist

Brandon, if you’d like to send the stuff my way (evulish[at]epix.net) I could make an attempt to make a plugin for XMMS for the…what? 3 linux users here :slight_smile: Not that I’ll ever use it or anything…but just to make an attempt at programming C :slight_smile:

Auhg. GTK will be the death of me :rolleyes:

oops… sent it to the registered yahoo address, for your forum account…

o0o. Ok, I got it. I figured it out, actually. Well, besides the md5’d password :slight_smile: Anyone know how to create md5 sums in C? :stuck_out_tongue:

The configuration is working…now I need to just create the socket stuff (since there’s no default browser or anything…the HTTP protocol is simple enough.)

I wish I had a better understanding of C. I don’t totally get header files yet :stuck_out_tongue: Though I must say I’m not doing too bad since my own teacher knows nothing about C (yeah…I’m teaching myself…like everything else I have ever learned about computers). Well, it’s being created from the helloword plugin on the xmms.org plugins page. But I’m still doing a bit of the work. Most of the plugin layout was done for me…but now it’s modified.

I should be done within a week. Or not. I seem to never finish stuff :stuck_out_tongue: (I might actually be done tonight…figuring my headache goes away and I get all nicely registered for the SATs…gotta raise that 1210 into the 1300’S!)

The winamp script does not md5.
I store the md5 password in the config file. Use this utility to md5 a text string.
You may just wanna do that, instead of actually doing the md5()… unless you want to :slight_smile:

Well, I’d like to do it in C…just because I can :stuck_out_tongue: Well, at least I might. I’ll try. Hehe. Not sure what header file it’s in. Googles I don’t believe it’s standard…probably in a crypt package or something. Kernel header? Huh. Whatever.