Look ๐Ÿ‘€ new REV product - MAX Planetary Gearbox

Nope. Youโ€™re not the only one.

18 Likes

Could have done without all the bolded reminders that the contents of the post are factual.

18 Likes

Fact: Thatโ€™s just like, your opinion, man.

23 Likes

Fact: You forgot the bold font. It makes all the difference.

10 Likes

I read neither as hostile, yet cringed at both, knowing people would probably overreact due to imperfect wording on either

4 Likes

Fact: Bears eat beets.

19 Likes

I did email them and they told me it was a simple press to fit. It does not press to fit. We are using the redline 775 and have the 775 adapter kit. I saw another post somewhere that said they were told to sand down the shaft of their motor (different one than 775) to get the adapter on the motor. We are ready to resort to that in order to get our gearboxes together.

1 Like

We noticed some binding on one of our Max Planetary 3:1 stages, and when we took it apart we saw that the two parts that make up the sun gear have shifted slightly (top image), as compared to the correct position(bottom image). These two parts (that seem to be press-fit together in all of our other sun gears) can slide around pretty freely(can do it by hand easily) which allows it to move and grind against the gears of the next stage in the gearbox.
Has anyone else encountered this issue? Is there a way to get a replacement gear from REV? @Greg_Needel


send us an email to support@revrobotics.com and we will help get it taken care of.

Curious what application you were using this stage in. Any more details around the mechanism?

Itโ€™s from our climber, so pretty high torque demands, though not exceeding the specs(presumably)

In our testing we didnโ€™t see a failure like this, so it is my guess that you got one where the two parts were on the opposite limits of the tolerance range.

This is the first report we have had of this issue, but will pull a sampling and do some additional checking to confirm this is an isolated incident and post back here if there is anything to report.

8 Likes

Greg, we had a similar issue with a 3:1 stage although it wasnโ€™t quite able to be shifted by hand (pliers were enough though). We pressed the outer gear back into place and have seen no movement since. My initial guess had been that 2 stages were not quite lined up and engaged when a team member started torquing down the through bolts, thus applying a large shear force across the press fit interface.

Weโ€™re having issues with the 550 12t 32 dp and the gt2 pully pinions not being a press fit. They are a slip fit. We measured our motor shafts with a micrometer and they measure .124

This one is a known issue.

Rev helped me out with this.

Loctite 638 worked great. I should have checked their website before contacting them too, since they had already posted when I had the issues.

I believe a similar issue, specifically with the 3:1 stage is documented in @Boomie-7492 's open alliance thread.

Yep, in this post. 7492 CavBots - 2022 Build Blog - #42 by Boomie-7492

We had heard of the same issue on the FRC Discord, and they recommended using the closest clearance socket size (I want to say we did 20mm? Donโ€™t quote me on that) and pressing it flush. This seems to have worked and we have been running it on the practice bot (but itโ€™s clearly marked as โ€œdefectiveโ€ just in case)

For more context - this was right out of the box. We had assembled all of our MPs and found that one to be entirely impossible to rotate, and once we opened it up, we found that.

I thought we had reached out to REV support, but maybe not. My apologies.

I wanted to give an update to some of the 3:1 stage comments above as we have done more digging to figure out the root cause of these issue.

This issue only shows up when 2 situations are true.

  1. the 3:1 stage is the first one after the motor
    and
  2. the input coupler is not fully seated or aligned before the gearbox screws are installed

On the 3:1 stage the two parts that are pressed together (Blue/RED) , are of a similar diameter to the MP spline itself. If for some reason your input coupler (green) is not seated or aligned on the on the spline (blue part) and you tighten the gearbox together, the screw itself is acting as a press and can force the blue and red parts to separate, causing an interference with the next ratio stage.

We have updated our assembly order on our docs site to a process which will lesson the chance of this happening. NEO - MAXPlanetary System

There is always a small chance that there might be a manufacturing defect in a part that prevents these parts from going together, but after looking at lots of samples from our inventory we feel that it is far more likely that it was an assembly issue by the team that causes this to be seen. Either way, if you have experienced this issue, please email us support@revrobotics.com and we will get it taken care of.

25 Likes

Rev has a 775 motor adaptor. Does anyone know if that would work with a bag motor?

No, a 775 motor has a 5mm output shaft while a bag motor has a 4mm shaft.

1 Like