Losing Comms After Deploying


So we’ve been trying to get basic drive code running on our bot with all the new stuff. We’ve run into two issues:

First, some computers seem to not be able to deploy code to the robot or visit the web dash with the target set as roborio-4557-FRC.local . They also aren’t able to ping the robot at that location. They are, however, able to do all this at . One computer is able to do this, though (the one with Itunes on it, and therefore also Apple’s Bonjour thing). Screenshot 1 is an image of the error message when trying to reach the web dash. Screenshot 2 is the diagnostics tab of the DS.

Second, the computer that is able to use the roborio-4557-FRC.local, when we try to deploy the LabVIEW code, it seems to deploy successfully, but immediately after that, we get an error message that says that Communication to the Target has been lost. The comms light stays green. We’ve also been able to deploy successfully with code without using the CTRE library.

I’d be happy to provide any more info, and any help is appreciated.



Mark, perhaps the following questions might give us more insight on what might be causing this behavior:

  • Have you used the same Ethernet/USB cable for all your tests? (you might want to try a different one to see if it’s not a fault related to it)
  • Is your power source stable? (i.e. have you tried another battery or a 12V DC adapter)
  • Are you using the administrator user in the computers? Have you tried running the DS and LabVIEW in Administrator mode?
  • Is there any additional Firewall or antivirus enabled in your computers that might be blocking the communication with the roboRIO?

Let us know your results.