Major problems transfering code to RC

Using the IFI Loader Application we are unable to send our (default 2006) code to the 2006 RC (we are testing 2006 code until the build subteam has gotten further with the development of the 2007 bot). We are receiving the error “To enable download, hold the program LEDs down until orange” even though the cable is connected and we have set the robot appropriately. We have tried two laptops and have run tests (loopback test) on both machines to confirm functioning serial ports/drivers. COM1 is selected and bitrate is set at 115200. We have tried running a realtime COM port monitor and this has shown the IFI loader attempting to send some hex data through the port, but the RC is not receiving it. Through all diagnostics so far the problem appears to be either with the IFI Loader software or with the RC itself. Does anyone have any insight to offer on this situation?

I’d just like to say we have the same problem with our RC. Thinking that it was the USB->Serial adapter on my computer, we tried a different computer, but the problem remained. We’ve also tried the reset button on the RC. Downloading to last year’s robot still works, however.

We reloaded IFI and that worked temporarily. We have not found a permenant fix. We have even tried different computers (2-2006’s 1 2007)

Call IFI’s TECH support. they will run you through some steps. If these dont work they will possibly have you send it to them. My controller didn’t want to read from 2 computers which work flawlessly with the 06 controller. I am sending our 07 controller in friday to IFI.

-Mike

We called IFI and they had a solution. We did this a while ago so the steps may not be exact but I recommend you try these steps:

  1. Unplug battery/power and plug back in
  2. Hold down the PROG and RESET buttons on the RC for about 15 seconds then let go of RESET and continue to hold PROG until the green light turns from blinking to solid. At this point release PROG. (I may have the buttons backwards so check other threads/try the reverse if that doesn’t work)
  3. connect the programming cable to the pc and open the MASTER file. This is a .BIN file so you will need to switch file type in the file browser. If you do not have this file download it from IFI’s site.
  4. Make sure that the OI is plugged through Tether into the RC so both units are on.
  5. Press download
  6. The master code should go over. If it doesn’t check your settings and call IFI
  7. If it does, proceed to send over the default code.
  8. You should be fixed, worked for us, good luck to you!

Where on exactly on the site is the master? Thanks

http://www.ifirobotics.com/docs/frc-code-2007-8722.zip File is FRC_MASTER_V13.BIN. The default hex file that can be used is in the file also - FRC_Default.hex.

This is linked to off of the http://www.ifirobotics.com/rc.shtml robot controller page.

This may not be your problem but this is a great place to make an important comment.

I do a LOT of serious development work in my day job and have to use USB-RS232 cable every day for many things.

Many cable do not work correctly, including ones based on the Prolific chipset.

As far as I can determine, the “gold” standard is the cables based on the FTDI 232 chipset. Here is a cable based on this chipset.

http://www.usbgear.com/computer_cable_details.cfm?sku=USBG-232&cats=199&catid=199,461,106,1009,601

Another one is:

http://www.rabbitsemiconductor.com/products/rs232_usb_cable/index.shtml

My experience has shown that the IFI downloader works reliably ONLY with the cable based on this chipset. Same scenario with the Rabbit and a few other toolsets.

Ed