mDNS and the Driver Station

We’re trying to streamline our development and control process by being able to connect to the robot wirelessly and to the internet at the same time.

To accomplish this we have a wired ethernet switch with a wireless router connected to it with DD-WRT installed in client bridge mode. The router bridges to the robot’s D-Link router wireless network. Our development laptops plug into the ethernet switch to connect to the robot and we can still use our wireless adapters on the laptops to connect to the internet.

The problem is that the DD-WRT router doesn’t seem to be passing the mDNS packets through the bridge. If I turn off “use mDNS” for the Java Smartdashboard it is able to connect to the robot. If I add the line:


to my laptop’s hosts file then I can deploy code to the robot using Eclipse and I can get to the robot’s web dashboard but putting “roboRIO-5190.local” in my browser. The Driver Station though still refuses to connect no matter what I do. Is there a way to turn off using mDNS with the Driver Station? Is there a better way for us to wirelessly connect to the robot and the internet at the same time?

Obviously the best thing would be to figure out how to get the mDNS packets to pass through the DD-WRT bridge but I’ve been unsuccessful with figuring that out so far.

How about reversing your connections.
Use the wireless router to connect to your Internet router and use the built-in wireless of the laptops to connect directly to the robot’s DLink.

Does the router have any firewalls operating?
Are you using a TimeWarner DNS server?

That’s a pretty good idea. I would like to avoid doing that though if I can because we work out of 2 different locations with two different wifi networks so we would have to reconfigure the bridge everytime we move to the other location but if it comes down to it that’s what we’ll do.

Are you trying to connect the development computer to both the roboRIO and internet simultaneously? If you are using a laptop, you can change the system settings that turn off the wireless when connected to a LAN. This is often in the system BIOS.

This is almost certainly because the OS is using your wifi adaptor as the primary interface and routing all unknown destination packets (like mdns requests) out of that. When you specify the IP manually the packets are routed out ethernet, since you have an IP address in that subnet.

In Mac OS, there is a way to set service order of interfaces, so you can pick a default interface. I don’t know how this works in windows. Why don’t you hook up an internet enabled ethernet cable to the WAN port of your router and just join the robot’s wireless network?

We do this slightly differently.

  1. Switch the robot’s DAP-1522 into bridge mode
  2. Set up a different wireless router to create the 610 SSID, and act as a DHCP server and default gateway for the subnet - we usually put this on for legacy reasons (the old control system used to have a seperate wireless router on this IP)
  3. Connect the internet to this separate wireless router

This setup more closely resembles the FMS setup as well. We usually try and setup everything over the 5GHz to avoid congestion.

Programmers can check out and commit code, and Google solutions, all while communicating with the robot.

I highly recommend all teams run a setup that allows this.