Measuring CAN bus utilization on CANivore

Was taking a look at the CANivore user guide and in it it’s mentioned that you’re able to measure the can bus utilization (presumably on the CANivore?). How would I go upon measuring the util on the CANivore if it’s possible?

2 Likes

6 Likes

When I tried to access the CANivore from Phoenix Tuner I was getting a permission error: Phoenix Tuner wasn’t able to modify the usr/local/bin/caniv file (due to permission errors). This happened multiple times after restarting phoenix tuner and so I tried sshing into the roborio and changing the permissions so that any user can read or write but I ended up not being able to from the lvuser account. Is it safe to change the permissions of the file from the admin account so I can access the canivore from Phoenix Tuner? Is there something else I should do?

1 Like

You mention that you ssh’d into the RIO using the lvuser account - this isn’t really common so I want to ask: what is your account setup on your roboRIO?

Phoenix Tuner uses the RIO’s admin account with default credentials. If you’ve modified those and are now using non-admin credentials (like lvuser) in Phoenix Tuner that would explain the kinds of issues you’re seeing. Otherwise Tuner would be using the admin account and wouldn’t have issues with permissions.

If you’ve modified the credentials I recommend putting them back to the default and then Tuner should work as expected. You may need to re-image the RIO in order to do this since the default password is blank.

Alternatively you can ssh in with the admin account to change the permissions but this is a hack that won’t fix the root issue.

3 Likes

Thanks for the help! I haven’t changed the account structure of the roboRIO in anyway. Both the lvuser and admin account don’t have passwords. I also haven’t modified the account Phoenix Tuner uses so I’m not sure what’s going on.

I’ll try to ssh in and fix the file permissions. I was planning to change the permission to read and write for all users, not sure if this is advised against though.

Additionally, this is the first time we’ve had this problem and we’ve used Phoenix Tuner all throughout the season. Afaik we’ve also been able to see our CANivore in the tab so it seems to be a more recent problem? If it isn’t the account structure that’s the problem, what could it be?

1 Like