Mecanum drive problems

We have been programming our robot in regards to driving, but are having problems getting all of our expected results. We are programming with the holonomic.vi and are controlling the robot with a 3-axis Logitech Extreme 3D Pro Joystick. As of right now, we are able to move forward, backwards, left, right, and in both a CW and CCW rotation. Our problems come in when we try to execute a left/right slide. Following is a list of how our robot acts in regards to joystick input:

Forward: All wheels forward
***Desired motion
Backward: All wheels backwards
***Desired motion
Left: No activity
***Would like to slide left
Right: No activity
***Would like to slide right
CCW turn: Robot turns CW
***Opposite of desired motion
CW turn: Robot turns CCW
***Opposite of desired motion

If anyone has any ideas on how we could fix this problem to allow our robot to slide, we would GREATLY appriciate it. In addition, if anyone has an idea of how to fix our inversion of our CW and CCW turns, that would be wonderful as well!!

What does “No activity” mean? What is the LED on each Jag doing? What are the PWM indicators in the Driver Station showing?

CCW turn: Robot turns CW
***Opposite of desired motion
CW turn: Robot turns CCW
***Opposite of desired motion

Just change the sign of the associated output from your joystick.

~

When we move the joystick to the left or the right, none of the motors react to the command, hence the “no activity.” All of the Jag’s LEDs stay yellow and there is no movement in the wheels, and the PWM indicators don’t show any changes either.

The default dashboard displays the joystick x-axis. Does it show any response to your left/right joystick motions? Remember that the dashboard updates only once per second.

~

There isn’t any response at all given in the display when the joystick is moved left/right.

what kind of code do you have for your joystick control. we were able to get some wheel movement using the std attack3, but unable to get movement with our code using extreme 3D pro. We will still be working on code, even after the bot ships today. …Building a test bed w/ the RIO to get the joystick interface worked out with the Mecanum wheels.

Here’s a screenshot of our current code for joystick control using the Extreme 3D Pro joystick.





No wonder you aren’t getting any noticeable directional control. The “Mecanum - Polar” vi wants a direction specified in degrees. You’re giving it the X axis of your joystick, which only ranges from -1 to 1.

I think all you need to do is change it to “Mecanum - Cartesian” and it should work as you expect. (You might also have to negate the sign of your rotation input, depending on whether your joystick twist has positive values to the left or to the right.)

We just switched the holonomic drive from “Polar” to “Cartesian” and everything is working properly now. Thanks for all of the help!!

We are also having problems getting the mecanum drive to work. We are using the based Labview Holonimic VI. We are using a Logitech Extreme 3D Pro single joystick with X Y and Axis 3 Throttle. In reading this post we did confirm that we have it set to Mecanum - Cartesian.

Only two of the 4 wheels spin. We are using Talons. Does not seem to be an electrical issue and appears to be a code problem.

Please help
Thanks

I’m going to start with the easy question: Which two wheels are moving?

Are your PWM cables plugged into the same ports you specified in Begin.VI?

What color are the LEDs on your Talons when you try to drive forward?

Hello and thank you for the quick reply
We worked on the bot some more this evening and detrimined that our CRio is the problem. We were getting only two wheels to run at any given time. We could switch around the pwm cables and get different wheels to run but only two at any given time. After a process if elimination we switched out the crio base unit and it worked.
We have two of the wheels on the left side going the wrong direction but we think we can correct this by switching the pwm settings around ?
Thanks very much

That doesn’t seem likely to be the problem. I suspect that the issue was resolved when you rewired or will show up again.

Do you have power plugged into the digital sidecar? Without power, the unit will often be able to drive a few speed controllers, but not four.

Greg McKaskle

The easiest way to fix this is to go into begin.vi and use the invert settings on the 4 Wheel Drive Open.

We seemed to have had our problem fixed, all 4 wheels ran after we tried another crio. But after I deployed the same program with minor changes to the non drive teliop system (adding some spikes), as soon as I enabled it it would run all wheels full speed for a second and then stop and I could not controll it. But if you enable it with the joystick moved ahead it will run however you want it to until you let go then it will lock up again. I uploaded three programms (one completely new one) and nothing worked. I think we had this problem last year. Any ideas?
Thanks!

Please tell us what the speed controller LEDs are doing when the problem occurs. Also describe the four green LEDs on the Digital Sidecar (three power indicators and the Robot Signal Light).

What you describe is vaguely consistent with the Digital Sidecar not receiving 12 volt power properly.