Microsoft LifeCam wireless issues

Hi everybody,
I have been struggling with communication between our robots usb camera and our computers driver station. In its current state, the camera will work when plugged in via usb, but not when connected wirelessly. We use labveiw for our robot. Any help would be appreciated. Thanks!

Try this:

  • Start and connect everything-roboRIO, Driver Station, Dashboard, etc.
    I assume you have at least the default code Run as Startup on the roboRIO.
  • Select the camera in the Dashboard (I assume you don’t see an image at this point)
  • Push the Reset button on the roboRIO case (leave everything else alone as-is)
  • Wait for the Driver Station to reconnect

See if the image comes up on it’s own.

I tried hitting the reset button on the case with the default code deployed and run at startup on the robot. It failed to work wirelessly but worked even before the reset when plugged in via usb cable.

Alright so I updated the WiFi adapter and now the camera works great both wirelessly and with a usb connenction.

Was the PC an old one?

I think advising people to update their network adapters may help a lot of people having problems connecting.

No it was rather new but there was an update available. Upon further testing, I think it was more the disabling and re-enabling the update caused the adapter to do. I now have to disable and re-enable my WiFi adapter upon each power cycle.