MKCad - 2023 Season Updates

I’ve noticed that the pneumatics dropdown is missing. Was this an accident?

1 Like

Yes. that was a mistake. thank you for catching it. we’ll work to get it added soon.

1 Like

Can you add a simplified version of the Max Planetary? The model manages to have every single ball bearing and gear, and it impacts load times a bit, just deleting the gears and balls should be good enough.

There is also a random floating 90-degree gearbox every time you import a max planetary, it doesn’t do anything but its a bit annoying.

The REV through-bore encoder is only named by its SKU, is it possible to add a name to it? It makes it hard to find.

1 Like

I can pass this up to REV and see if they can help. MKCad just derives / linked the REV Onshape models.

Yes! Introduction to the FTC Parts Library - Using Onshape for FTC

Ive noticed that I cant seem to find the configurable versaplanetary tab anymore. Was this removed?

I just updated the the Max Planetary assembly so that there is not a random floating 90 degree gearbox.

I mentioned this to REV a few days ago. I don’t know how much of a priority this is for them.

Hoping we could get the simplified MPM updated to proper dimensions.
Currently the hole spacing and overall size on the width is okay but both dimensions in the length are over by 1 inch. Almost sent out our bellypan with these oversized dimensions because of this.

Try now

1 Like

Should be fixed

The Configurable VersaPlanetary assembly is now under the gearboxes header. If you still don’t see it, give Onshape a quick refresh and open the MKCAD app again.


When I use MKCad to import a max planetary I’m getting the 90 degree gearbox at the origin of my assembly. Am I doing something wrong or is this a bug?

This was hopefully fixed this morning. If the MAX Planetary was inserted beforehand, you’ll need to update that assembly. If you inserted it after 10:30 AM CST today and still have this issue, please let us know.

1 Like

Re: this discussion incorrectly initiated on the 2021 MKCad update thread, I can find the through bore encoder using Insert, but I don’t see it in the app. I tried using Chrome and Edge, and revoked, cleared temp browser data, then re-granted, but it is still not showing up. Using Insert is no big deal (use it for plenty of other stuff), but since C&C said it’s in the app, it seems worth asking about given other users might not be seeing some parts as well. Are there MKCad reset instructions? Maybe I didn’t do it correctly. Thanks.

Refresh the page and try now. I thought this was fixed but apparently not.

Yesterday I was using mkCad and used a configurable sprocket generator, was it removed from mkCad because I can’t find it now

Not removed, it was just hidden. It should be visible now - give it a couple minutes and refresh your Onshape tab, and it’ll be under the Sprockets header again.

Thank you so much!


Is thee a way to make the Thrifty Elevator configurable for height?

What category is the AM14U5 in now? I cannot seem to find it to insert the configurable chassis. (Other configurable parts do seem to be working.)