More Radio Configuring Problems

I’ve looked into solutions presented in both chiefdelphi threads but none has worked for me.

Radio Configuration Problems (2016)

Bridge configuration failed on OM5P-AN radio (2016)

I keep on getting this error when clicking on “Configure”.

Relevant Info:
I’ve tried two routers.
These two routers have worked in past years (2017-2020).
The power led (blue) turns on.
The ethernet led (blue) turns on.
The wifi led (orange) did turn on but no longer turns on after loading the firmware.

Please help

Have you tried using a different PC? Is the laptop shown in the picture successfully configured a radio in the past?
You can also check the solutions offered here:


I have tried using a different PC. And neither have successfully configured a radio in the past.

Looking through those threads you posted, the solutions presented do not work for me. I’m in the US and do not have any problems with broken Ethernet adapter names. I will look into it though.

You may have already done this - be sure your wireless adaptor is disabled before attempting imaging. We had problems where windows wanted to help by switching the connection to wireless because wired did not have internet access (when connected to the radio)


By wireless adaptor do you mean this?

and if so, yes. I have made sure to disable All other adaptors but the one ethernet connection. I’ve done this process on three different computers but no luck. Thank you though!

Not sure this applies, but based on the picture you posted…

Be sure you are configuring over an Ethernet cable, with WiFi turned off.

I imagine this is what you are doing, but the picture shows wired Ethernet disabled and WiFi enabled.

Ethernet is not disabled, it just doesn’t have a cable plugged in (detected). But WiFi is still enabled.

If that pic is from an attempt to configure the radio, then something is up for sure with the Ethernet connection. I would swap cables, and/or try another laptop.

1 Like

This picture is not of an attempt at configuring the radio just my everyday usage of my deskktop. However, yes I would disable all other network adapters other than the ethernet while configuring the radio.

So it would seem that using a different pc and ethernet cable will be what I try next. I’ll be sure to update when that happens.

1 Like

We have this same problem. In the past, we have solved it by using a desktop instead of a laptop. I has something to do with the very fragile way the configuration tool identifies and uses your network connection. Have you tried renaming your network connection? maybe with no space? Also, if you can try other computers. This a VERY frustrating problem, that should be handled by the software.

What java version(s) do you have installed?

Does the Radio Configuration Utility require a specific version of Java? If so, what version?

There was an update to Java that causes the address setting to fail. Any 16.0.1, 11.0.11 and 8u291 all have the change that causes the failure. However, because of how WPILib handles versions, if you install 2020 WPILib, you’ll get a version of Java 11 that works again. See the Known Issues in the docs for more information



1 Like

Fixed the problem for me as well.

I am sorry I have the same issue its showing me same IP address error when I am trying to configure the openmesh radio. Then according to your suggestion I Look for 2020 WPILIB download link. I didn’t find any 2020 WPILIB download link all I get is 2022. Could you please help me to find the link for 2020 WPILIB so that I can install it and solve this issue. Thank you

1 Like

What version of the radio tool are you using? The 2022 radio tool fixed the java incompatibility, so it’s no longer necessary to download the 2020 WPILib to get an older version of java.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.