Motor Error

We are getting this error:

Missing Module: Digital Module 1>>WPI_MotorControlOpen&>>WPI_MotorControlOpen>>>>>>Robot
<time>00:11:58 01/01/1970<unique#>3162

We are getting this error in WPI_RobotDriveRefNum Registry Front Panel on 2012 Robot.

We’re trying to get the robot to drive off of the basic program that FRC provides. The Jaguar speed controllers flash yellow. Also, the ribbon cable has been fixed.

Is the Digital Module that the ribbon cable is attached to in Slot 2 of your cRIO?

It is either in slot 1 or slot 4. We don’t know which one is the front. If the ethernet port is on the right where the observer it is in the furthest slot to the left.

It belongs in Slot 2. Slot 1 is the side with the Ethernet port on it. Move the Digital Module and see if the error clears (the green LED next to the white 2 pin header on the Digital Sidecar should also start blinking).

Well we got one of the motors working without fixing the physical slot. We changed something to digital module 2 but only one motor works now.

we also have the controlled mapped to both motors so it has to be something in labview

If you have it in slot 4 you can get things working by using Digital Module 2 in LabVIEW, but per the rules you must have a Digital Module in Slot 2 of the cRIO so you might as well move it now.

Just mioved it and the same problem, however we were seeing the PWM outputs both times and nothing was happening so we replaced the non moving jaguar and nothing is working again. Both sides are jaguars by the way.

Tried putting from PWM 1 and 2 to PWM 1 and 3 for both motors. PWM 1 is the working one